Why is a 1G NIC transmitting at much higher speeds?

Solution Verified - Updated -

Issue

  • Abnormally high txkB/s in sar output.
# sar -f /var/log/sa/sa14 -n DEV -s 12:00:00 -e 13:00:00 
Linux 3.10.0-693.17.1.el7.x86_64 (localhost)        09/14/2018      _x86_64_        (8 CPU)
12:00:01 PM     IFACE   rxpck/s   txpck/s    rxkB/s    txkB/s   rxcmp/s   txcmp/s  rxmcst/s
12:10:01 PM        lo     19.39     19.39      6.00      6.00      0.00      0.00      0.00
12:10:01 PM     ens33   1698.07   7953.26    107.45  19378.04      0.00      0.00      0.00
12:20:01 PM    ens192      0.18      0.00      0.01      0.00      0.00      0.00      0.00
12:20:01 PM        lo   3921.78   3921.78   1114.73   1114.73      0.00      0.00      0.00
12:20:01 PM     ens33  84182.81 1192887.93  30366.47 3043721.98      0.00      0.00      0.00
12:30:01 PM    ens192      0.00      0.00      0.00      0.00      0.00      0.00      0.00
12:30:01 PM        lo      3.37      3.37      0.67      0.67      0.00      0.00      0.00
12:30:01 PM     ens33    228.71    714.81     14.60   1673.13      0.00      0.00      0.00
12:40:01 PM    ens192      0.00      0.00      0.00      0.00      0.00      0.00      0.00
12:40:01 PM        lo      5.81      5.81      1.35      1.35      0.00      0.00      0.00
12:40:01 PM     ens33     62.21    170.10      4.91    391.78      0.00      0.00      0.00
12:50:01 PM    ens192      0.00      0.00      0.00      0.00      0.00      0.00      0.00
12:50:01 PM        lo      5.50      5.50      1.28      1.28      0.00      0.00      0.00
12:50:01 PM     ens33    896.13   2446.59     55.93   5851.44      0.00      0.00      0.00
Average:       ens192      0.04      0.00      0.00      0.00      0.00      0.00      0.00
Average:           lo    787.51    787.51    223.67    223.67      0.00      0.00      0.00
Average:        ens33  17078.74 239310.85   6090.09 610498.51      0.00      0.00      0.00
  • The link seems to be mucher achieving faster speeds than what ethtool advertises. Is this a bug or some kind of reporting error?
Settings for ens33:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: off (auto)
    Supports Wake-on: d
    Wake-on: d
    Current message level: 0x00000007 (7)
                   drv probe link
    Link detected: yes

Environment

  • Red Hat Enterprise Linux (RHEL)
  • Virtual Machines with 1G NICs such as e1000

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In