Yumdownloader returns different results than 'yum install --downloadonly'

Solution Verified - Updated -

Issue

  • On system running RHEL 6.3, yum install kvm --downloadonly successfully finds the kvm package
[root@unused pluginconf.d]# yum install kvm --downloadonly
Loaded plugins: downloadonly, product-id, refresh-packagekit, rhnplugin, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package qemu-kvm.x86_64 2:0.12.1.2-2.295.el6_3.8 will be updated
---> Package qemu-kvm.x86_64 2:0.12.1.2-2.355.el6_4.2 will be an update
--> Processing Dependency: qemu-img = 2:0.12.1.2-2.355.el6_4.2 for package: 2:qemu-kvm-0.12.1.2-2.355.el6_4.2.x86_64
--> Processing Dependency: seabios >= 0.6.1.2-20.el6 for package: 2:qemu-kvm-0.12.1.2-2.355.el6_4.2.x86_64
--> Processing Dependency: libspice-server.so.1(SPICE_SERVER_0.11.2)(64bit) for package: 2:qemu-kvm-0.12.1.2-2.355.el6_4.2.x86_64
--> Processing Dependency: libspice-server.so.1(SPICE_SERVER_0.10.4)(64bit) for package: 2:qemu-kvm-0.12.1.2-2.355.el6_4.2.x86_64
--> Processing Dependency: libusbredirparser.so.1()(64bit) for package: 2:qemu-kvm-0.12.1.2-2.355.el6_4.2.x86_64
--> Running transaction check
---> Package qemu-img.x86_64 2:0.12.1.2-2.295.el6_3.8 will be updated
---> Package qemu-img.x86_64 2:0.12.1.2-2.355.el6_4.2 will be an update
---> Package seabios.x86_64 0:0.6.1.2-19.el6 will be updated
---> Package seabios.x86_64 0:0.6.1.2-26.el6 will be an update
---> Package spice-server.x86_64 0:0.10.1-10.el6 will be updated
---> Package spice-server.x86_64 0:0.12.0-12.el6 will be an update
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: spice-server-0.12.0-12.el6.x86_64
---> Package usbredir.x86_64 0:0.4.3-1.el6_3 will be updated
--> Processing Dependency: libusbredirparser.so.0()(64bit) for package: spice-glib-0.11-11.el6_3.1.x86_64
--> Processing Dependency: libusbredirparser.so.0()(64bit) for package: spice-gtk-python-0.11-11.el6_3.1.x86_64
--> Processing Dependency: libusbredirparser.so.0()(64bit) for package: spice-gtk-0.11-11.el6_3.1.x86_64
---> Package usbredir.x86_64 0:0.5.1-1.el6 will be an update
--> Running transaction check
---> Package libjpeg.x86_64 0:6b-46.el6 will be obsoleted
---> Package libjpeg-turbo.x86_64 0:1.2.1-1.el6 will be obsoleting
---> Package spice-glib.x86_64 0:0.11-11.el6_3.1 will be updated
--> Processing Dependency: libspice-client-glib-2.0.so.1()(64bit) for package: virt-viewer-0.5.2-9.el6.x86_64
--> Processing Dependency: libspice-client-glib-2.0.so.1(SPICEGTK_1)(64bit) for package: virt-viewer-0.5.2-9.el6.x86_64
---> Package spice-glib.x86_64 0:0.14-7.el6 will be an update
---> Package spice-gtk.x86_64 0:0.11-11.el6_3.1 will be updated
---> Package spice-gtk.x86_64 0:0.14-7.el6 will be an update
---> Package spice-gtk-python.x86_64 0:0.11-11.el6_3.1 will be updated
---> Package spice-gtk-python.x86_64 0:0.14-7.el6 will be an update
--> Running transaction check
---> Package virt-viewer.x86_64 0:0.5.2-9.el6 will be updated
---> Package virt-viewer.x86_64 0:0.5.2-18.el6_4.2 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                           Arch                                    Version                                                     Repository                                             Size
===================================================================================================================================================================================================================
Installing:
 libjpeg-turbo                                     x86_64                                  1.2.1-1.el6                                                 rhel-x86_64-server-6                                  174 k
     replacing  libjpeg.x86_64 6b-46.el6
Updating:
 qemu-kvm                                          x86_64                                  2:0.12.1.2-2.355.el6_4.2                                    rhel-x86_64-server-6                                  1.3 M
Updating for dependencies:
 qemu-img                                          x86_64                                  2:0.12.1.2-2.355.el6_4.2                                    rhel-x86_64-server-6                                  470 k
 seabios                                           x86_64                                  0.6.1.2-26.el6                                              rhel-x86_64-server-6                                   91 k
 spice-glib                                        x86_64                                  0.14-7.el6                                                  rhel-x86_64-server-6                                  291 k
 spice-gtk                                         x86_64                                  0.14-7.el6                                                  rhel-x86_64-server-6                                   54 k
 spice-gtk-python                                  x86_64                                  0.14-7.el6                                                  rhel-x86_64-server-6                                   22 k
 spice-server                                      x86_64                                  0.12.0-12.el6                                               rhel-x86_64-server-6                                  326 k
 usbredir                                          x86_64                                  0.5.1-1.el6                                                 rhel-x86_64-server-6                                   40 k
 virt-viewer                                       x86_64                                  0.5.2-18.el6_4.2                                            rhel-x86_64-server-6                                  200 k

Transaction Summary
===================================================================================================================================================================================================================
Install       1 Package(s)
Upgrade       9 Package(s)

Total download size: 3.0 M
Is this ok [y/N]: 
  • Yumdownloader fails to:
[root@~]# yumdownloader kvm
Loaded plugins: product-id, rhnplugin
No Match for argument kvm
Nothing to download

Environment

  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 5

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In