"Invalid content was found starting with element 'globals'" is thrown when enabling WS-Security after applying SOA 5.3.1 Roll-up patch #1

Solution Unverified - Updated -

Issue

  • I am trying to apply the security patch BZ-915386 which has a note on it related to enabling 'WS-Security' with the patch applied by using a <globals><war-security> configuration element at the beginning of the jboss-esb.xml file as is shown in the patch.
  • When I start up 'JBoss Enterprise SOA-P 5.3.x' server, I get the following error:
ERROR [ModelParser$XmlErrorHandler] ERROR-null-3:cvc-complex-type.2.4.a: Invalid content was found starting with element 'globals'. One of '{"http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.1.0.xsd":providers, "http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.1.0.xsd":services}' is expected.

Environment

  • JBoss Enterprise Service Oriented Architecture Platform (SOA-P)
    • 5.3.1 + SOA 5.3.1 Roll-up patch#1 (BZ-915386)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In