After Updating to CloudForms 4.6.2 External Yum Repositories Were Added

Solution Unverified - Updated -

Issue

  • After the update of the CloudForms appliance, moving from 4.6.0 to 4.6.2, during the post-scripts execution, several repositories are added to /etc/yum.repos.d/ :
[root@cf46 ~]# ls /etc/yum.repos.d/ -l
total 412
-rw-r--r--. 1 root root    211 May 18 11:06 ansible-el7.repo
-rw-r--r--. 1 root root    222 May 18 11:06 ansible-tower.repo
-rw-r--r--. 1 root root    640 May 18 11:06 epel-7.repo
-rw-r--r--. 1 root root    327 May 18 11:06 jlaska-rabbitmq.repo
-rw-r--r--. 1 root root    440 May 18 11:06 pgdg-96-centos.repo
-rw-r--r--. 1 root root 400851 May 18 10:39 redhat.repo
  • The appliance is now pointing to external repositories. A new 'yum update' would install unsupported versions of the software:
# yum check-update
Loaded plugins: product-id, search-disabled-repos, subscription-manager

ansible.noarch                                                                                           2.5.3-1.el7.ans                                                                            ansible        
erlang.x86_64                                                                                            19.0.4-1.el7.centos                                                                        jlaska-rabbitmq
nginx.x86_64                                                                                             1:1.12.2-2.el7                                                                             epel           
nginx-all-modules.noarch                                                                                 1:1.12.2-2.el7                                                                             epel           
nginx-filesystem.noarch                                                                                  1:1.12.2-2.el7                                                                             epel           
nginx-mod-http-geoip.x86_64                                                                              1:1.12.2-2.el7                                                                             epel           
nginx-mod-http-image-filter.x86_64                                                                       1:1.12.2-2.el7                                                                             epel           
nginx-mod-http-perl.x86_64                                                                               1:1.12.2-2.el7                                                                             epel           
nginx-mod-http-xslt-filter.x86_64                                                                        1:1.12.2-2.el7                                                                             epel           
nginx-mod-mail.x86_64                                                                                    1:1.12.2-2.el7                                                                             epel           
nginx-mod-stream.x86_64                                                                                  1:1.12.2-2.el7                                                                             epel           
postgresql96.x86_64                                                                                      9.6.9-1PGDG.rhel7                                                                          pgdg96         
postgresql96-libs.x86_64                                                                                 9.6.9-1PGDG.rhel7                                                                          pgdg96         
python-jinja2.noarch                                                                                     2.8-7.rhel7                                                                                pgdg96         
qpid-proton-c.x86_64                                                                                     0.21.0-3.el7                                                                               epel           
rabbitmq-server.noarch                                                                                   3.6.9-1.el7.centos                                                                         jlaska-rabbitmq
Security: kernel-3.10.0-862.2.3.el7.x86_64 is an installed security update
Security: kernel-3.10.0-693.17.1.el7.x86_64 is the currently running version

Environment

  • Red Hat CloudForms 4.6 (CFME 5.9)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content