JBoss EAP admin console prompts for user/password multiple times when accessing the console

Solution Unverified - Updated -

Issue

  • Authentication fails or prompt for username and password is repeated multiple times.
  • Log shows repeated LDAP queries and has error message:

    2018-04-12 09:23:47,658 ERROR [io.undertow.request] (management task-3) UT005071: Undertow request failed HttpServerExchange{ POST /management request {Accept=[application/dmr-encoded], Accept-Language=[en-US], Cache-Control=[no-cache], Accept-Encoding=[gzip, deflate], User-Agent=[Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; InfoPath.3; wbx 1.0.0)], Connection=[Keep-Alive], Authorization=[Basic errrblahblah==], Content-Type=[application/dmr-encoded], Content-Length=[312], Cookie=[imacookie=blahblah;], Referer=[http://imaserver.test.redhat.com:9990/console/App.html], Host=[imaserver.test.redhat.com:9990]} response {X-Frame-Options=[SAMEORIGIN]}}: java.lang.IllegalStateException: ELY01000: Authentication name was already set on this context
    

Environment

  • Red Hat JBoss Enterprise Application Platform (JBoss EAP)
    • 7.0
    • 7.1 or later with Legacy Security
  • Lightweight Directory Access Protocol (LDAP) or Microsoft Active Directory Lightweight Directory Service (AD)
  • Management Console or CLI authentication

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In