Unable to register a new RHEV_H to Red Hat Enterprise Virtualization 3.5

Solution Unverified - Updated -

Issue

While adding a new host in RHEV-M, it shows an error with yum dependency:

2018-03-29 13:01:49 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:88 Yum Building transaction
2018-03-29 13:01:51 ERROR otopi.plugins.otopi.packagers.yumpackager yumpackager.error:97 Yum [u'libvirt-lock-sanlock-2.0.0-10.el7_3.9.x86_64 ben\xf6tigt libvirt-daemon = 2.0.0-10.el7_3.9']
2018-03-29 13:01:51 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/tmp/ovirt-4G6tsImtK5/pythonlib/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/tmp/ovirt-4G6tsImtK5/otopi-plugins/otopi/packagers/yumpackager.py", line 261, in _packages
    if self._miniyum.buildTransaction():
  File "/tmp/ovirt-4G6tsImtK5/pythonlib/otopi/miniyum.py", line 917, in buildTransaction
    raise yum.Errors.YumBaseError(msg)
YumBaseError: [u'libvirt-lock-sanlock-2.0.0-10.el7_3.9.x86_64 ben\xf6tigt libvirt-daemon = 2.0.0-10.el7_3.9']
2018-03-29 13:01:51 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Package installation': [u'libvirt-lock-sanlock-2.0.0-10.el7_3.9.x86_64 ben\xf6tigt libvirt-daemon = 2.0.0-10.el7_3.9']
2018-03-29 13:01:51 DEBUG otopi.transaction transaction.abort:131 aborting 'Yum Transaction'
2018-03-29 13:01:51 INFO otopi.plugins.otopi.packagers.yumpackager yumpackager.info:92 Yum Performing yum transaction rollback

Environment

  • Red Hat Enterprise Virtualization 3.5
  • Red Hat Enterprise Linux Server release 7.4 (Maipo)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content