camel-sallesforce component does not support the latest cometD version

Solution Verified - Updated -

Issue

  • Salesforce 18 winter release implies upgrading Streaming API. This in turn requires upgrade of the CometD library to at least 3.1.0 version.
  • Camel-salesforce component within our Fuse build 6.2.1.redhat-084 refers to CometD library of 2.4.3 version. The latest available salesforce component includes CometD of 3.0.10 version, which is also unacceptable.
    Could you please advise what the options are to be compliant with the Salesforce release?

They say that earlier version of the library are no longer supported and could result in unexpected behavior. It seems we must somehow to upgrade the library.

Environment

  • Red Hat JBoss Fuse
    • 6.2.1
    • 6.3.x
  • Apache Camel
    • camel-cometd
    • camel-salesforce

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In