Why Does Ansible Fail Against Managed Nodes Running Python 2.5 or older?

Solution In Progress - Updated -

Issue

Ansible 2.4 or later fails to manage nodes running python 2.5 or older

Environment

  • Ansible Core 2.4+ (controller node)
  • Python <= 2.5 (remote host)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In