Red Hat Insights showing Organization is configured in disconnected mode.

Solution Verified - Updated -

Environment

  • Red Hat Satellite 6.x
  • Red Hat Insights

Issue

  • After installing insights-client in Satellite Server.
  • On Satellite WebUI showing error as Organization is configured in disconnected mode.

alt text

Resolution

  • Change the Red Hat CDN URL in satellite Manifest URL to https://cdn.redhat.com

    Go to Satellite Web UI > Content > Subscriptions > Click on "Manage Manifest" button, here change the Red Hat CDN URL
    

Root Cause

  • Incorrect Red Hat CDN URL in satellite Manifest, for example, http://cdn.redhat.com or https://cdn.redhat.com/

Diagnostic Steps

  • Command to check the connection from the client to Satellite Server.

    # insights-client --test-connection
    
    Could not auto configure, falling back to static config
    See /var/log/insights-client/insights-client.log for additional information
    Connection test config:
    Proxy config: {'https': 'http://proxy.exmaple.com:8080'}
    Certificate Verification: /etc/insights-client/cert-api.access.redhat.com.pem
    === Begin Certificate Chain Test ===
    Failed to connect to https://cert-api.access.redhat.com/r/insights. Invalid hostname.
    

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments