httpd service failed to start with error "Can't load Perl module PXT::ApacheHandler for server" after upgrade to Satellite 5.8

Solution Verified - Updated -

Issue

  • Upgraded to Satellite 5.8 when restarted httpd service, it failed to start.
  • Following errors reported in /var/log/httpd/error_log file.
Can't locate PXT/ApacheHandler.pm in @INC (@INC contains: /var/www/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /etc/httpd) at (eval 5) line 3.\n
[error] Can't load Perl module PXT::ApacheHandler for server satellite.example.com:0, exiting...

Environment

  • Red Hat Satellite 5.8

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In