Yum throws a conflict error while upgrading samba to samba3x package in Red Hat Enterprise Linux 5.

Solution Verified - Updated -

Issue

  • yum throws a conflict error while upgrading samba to samba3x package in Red Hat Enterprise Linux 5.
        # yum install samba3x -y

        Loaded plugins: rhnplugin, security
        Setting up Install Process
        Resolving Dependencies
        --> Running transaction check
        ---> Package samba3x.i386 0:3.3.8-0.51.el5 set to be updated
        --> Processing Dependency: samba3x-common = 3.3.8-0.51.el5 for package: samba3x
        --> Processing Dependency: libwbclient.so.0 for package: samba3x
        --> Running transaction check
        ---> Package samba3x-common.i386 0:3.3.8-0.51.el5 set to be updated
        ---> Package samba3x-winbind.i386 0:3.3.8-0.51.el5 set to be updated
        --> Processing Conflict: samba3x-winbind conflicts samba-common < 3.1
        --> Processing Conflict: samba3x conflicts samba-common < 3.1
        --> Processing Conflict: samba3x conflicts samba
        --> Processing Conflict: samba3x-common conflicts samba-common < 3.1
        --> Processing Conflict: samba3x-common conflicts samba
        --> Finished Dependency Resolution
        samba3x-common-3.3.8-0.51.el5.i386 from rhel-i386-server-5 has depsolving problems
          --> samba3x-common conflicts with samba-common
        samba3x-winbind-3.3.8-0.51.el5.i386 from rhel-i386-server-5 has depsolving problems
          --> samba3x-winbind conflicts with samba-common
        samba3x-common-3.3.8-0.51.el5.i386 from rhel-i386-server-5 has depsolving problems
          --> samba3x-common conflicts with samba
        samba3x-3.3.8-0.51.el5.i386 from rhel-i386-server-5 has depsolving problems
          --> samba3x conflicts with samba-common
        samba3x-3.3.8-0.51.el5.i386 from rhel-i386-server-5 has depsolving problems
          --> samba3x conflicts with samba
        Error: samba3x-common conflicts with samba
        Error: samba3x-winbind conflicts with samba-common
        Error: samba3x-common conflicts with samba-common
        Error: samba3x conflicts with samba
        Error: samba3x conflicts with samba-common

Environment

  • Red Hat Enterprise Linux 5

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In