JWS start up warns that `GLIBC_2.14' is not found

Solution Verified - Updated -

Issue

  • When starting JWS Tomcat on RHEL 6, we see the following warning:
WARNING: The APR based Apache Tomcat Native library failed to load. The error reported was [/path/to/tomcat7/lib/libtcnative-1.so: /lib64/libc.so.6: version 'GLIBC_2.14' not found (required by /path/to/tomcat/lib/libtcnative-1.so)]

Environment

  • JBoss Enterprise Web Server (JWS) 3.x
  • Tomcat

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In