Quartz timer retry issue in JBoss BPM Suite 6
Environment
- Red Hat JBoss BPM Suite (BPMS) 6
Issue
Due to database or network issues, the quartz trigger may fail for > 5 times and then eventually delete the quartz trigger. This may cause workflow to abnormally abort.
The Quartz trigger is deleted for a process instance, but the process instance is left in reserved state, thereby leaving the process instance in an idle state.
Resolution
This issue has been fixed in Red Hat JBoss BPM Suite 6.4 Update 1. The fix will allow users to configure number of retries and delay between retries via system property:
org.jbpm.timer.quartz.retries(default value is 5)org.jbpm.timer.quartz.delay(default value is 1000)
Root Cause
This issue has been reported in RHBPMS-4431.
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