yum update fails with, "Protected multilib versions: lua-5.1.4-15.el7.x86_64 != lua-5.1.4-14.el7.i686" Issue

Solution In Progress - Updated -

Issue

  • When performing a yum update I get the following error:

    Error: Package: lua-devel-5.1.4-14.el7.x86_64 (installed)
           Requires: lua = 5.1.4-14.el7
           Removing: lua-5.1.4-14.el7.i686 (@rhel-7-workstation-rpms)
               lua = 5.1
               lua = 5.1.4-14.el7
           Updated By: lua-5.1.4-15.el7.i686 (rhel-7-workstation-rpms)
               lua = 5.1
               lua = 5.1.4-15.el7
    
    • Updating the lua package fails with a multilib error:
    # yum update lua-5.1.4-14.el7.i686
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
    Package(s) lua-5.1.4-14.el7.i686 available, but not installed.
    No packages marked for update
    
  • yum fails with "No packages marked for update"

Environment

  • Red Hat Enterprise Linux 7.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In