Why does satellite certificate activation fail with "Unhandled exception: unsupported version: -1" ?

Solution Verified - Updated -

Issue

  • trying to activate Satellite server to Red Hat Network
  • error when running rhn-satellite-activate:

    # rhn-satellite-activate -vvv --rhn-cert=<path to cert>
    RHN_PARENT: satellite.rhn.redhat.com 
    HTTP_PROXY: <proxy hostname>:<port>
    HTTP_PROXY_USERNAME: <username> 
    HTTP_PROXY_PASSWORD: <password> 
    CA_CERT: /usr/share/rhn/RHNS-CA-CERT 
    Checking
    cert XML sanity and GPG signature: '/usr/bin/validate-sat-cert.pl
    --keyring /etc/webapp-keyring.gpg
    /etc/sysconfig/rhn/rhn-entitlement-cert.xml-25157-1265298973.70446110' 
    Database connectioned initialized: refer to default_db setting in /etc/rhn/rhn.conf 
    Attempting local RHN Certificate push (and therefore activation) 
    Executing: remote XMLRPC deactivation (if necessary). 
    Executing: remote XMLRPC activation call. 
    Error reported from RHN: <Fault -2: 'unhandled internal exception: unsupported version: -1'> 
    ERROR: unhandled XMLRPC fault upon remote activation: <Fault -2: 'unhandled internal exception: unsupported version: -1'> 
    
    ERROR: <Fault -2: 'unhandled internal exception: unsupported version: -1'> 
    

Environment

  • Red Hat Network Satellite

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In