Receive "main" java.lang.UnsupportedClassVersionError when trying to connect to MetaMatrix

Solution Verified - Updated -

Issue

  • I am getting following error while executing JDBCQueryExample.java with metamatrix-jdbc.jar and bcprov-jdk14-122.jar.  JAVA version is "1.4.1_01"
    • Exception in thread "main"
      java.lang.UnsupportedClassVersionError: com/metamatrix/jdbc/MMDriver
      (Unsupported major.minor version 49.0)
      

Environment

  • MetaMatrix Enterprise Server 5.5.3

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In