Horizon Dashboard times out with a 504 Gateway time out error

Solution Verified - Updated -

Environment

  • Red Hat OpenStack 7.0 (RHOS)

Issue

  • Horizon Dashboard fails to load page with HTTP 504 error ( Gateway timeout Error ) .

Resolution

  • If using a LDAP back-end for authentication, add the following clause in /etc/openldap/ldap.conf:

    NETWORK_TIMEOUT 2
    
  • Otherwise, please increase HAProxy timeouts as per Solution 1595673 and/or Solution 1465753.

Root Cause

  • This error indicates issue with haproxy reaching the backend server .
  • This can be cause due to considerable amount of time taken to reach the backend server .
  • If the backend server response is expected to take longer time that server timeout configured , server timeout can be increased in haproxy.conf .
  • Another possibility is that the maxconn limit is reached due to which all further connections to haproxy backend server fails .
  • This can be fixed by increasing maxconn in defaults/global section .

Diagnostic Steps

  • The issue is temporarily fixed by haproxy service restart .
  • Enable haproxy logging to confirm if timeout limit is hit by haproxy .

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