Deleting a user and then re-adding the same user shows user "already exists"

Solution In Progress - Updated -

Environment

  • Red Hat Satellite 6.x

Issue

  • Created user authenticated via LDAP. User is able to login.
  • Deleted user.
  • Tried to add user again via Administer-->Users-->New User.
  • User UI reports already exists although there is no listing of that account.

Resolution

  • User was only removed from Organization and/or Location but was not deleted from Satellite, refer below steps to delete user,

    • Login to Satellite WebUI and go to Administer tab, here click on Locations. If there are multiple Locations created then check each Location one my one. On opening a Location tab see Users tab, here check if user entry exists.

    • Similarly go to Administer tab and select Organizations , go to Users tab and check if user entry is there.

    • If user is there in Location and Organization then need to move this user to Selected Items for Location and Organization currently being used. The current Location and Organization can be seen at left hand top corner of Satellite WebUI.

    • After moving user to Selected Items now to delete it go to Administer-->'Users' tab. User should be listed here, need to click on 'Delete' link. This would delete user from Satellite and it should be possible to add same user again.

Root Cause

User was only removed from Organization and/or Location but was not deleted from Satellite

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.