Facing many missing dependency error messages while installing RHN Satellite v 5.4.1

Solution Verified - Updated -

Issue

  • Facing missing dependency error messages while installing RHN Satellite v 5.4.1
  --> Missing Dependency: perl(:MODULE_COMPAT_5.10.1) is needed by package perl-Apache-DBI-1.09-3.el6sat.noarch (/perl-Apache-DBI-1.09-3.el6sat.noarch)
libgsasl-1.4.0-5.el6sat.x86_64 from /libgsasl-1.4.0-5.el6sat.x86_64 has depsolving problems
  --> Missing Dependency: libc.so.6(GLIBC_2.8)(64bit) is needed by package libgsasl-1.4.0-5.el6sat.x86_64 (/libgsasl-1.4.0-5.el6sat.x86_64)
python-gzipstream-1.4.0-18.el6sat.noarch from /python-gzipstream-1.4.0-18.el6sat.noarch has depsolving problems
  --> Missing Dependency: python(abi) = 2.6 is needed by package python-gzipstream-1.4.0-18.el6sat.noarch (/python-gzipstream-1.4.0-18.el6sat.noarch)
libapreq2-2.13-5.el6sat.x86_64 from /libapreq2-2.13-5.el6sat.x86_64 has depsolving problems
  --> Missing Dependency: libexpat.so.1()(64bit) is needed by package libapreq2-2.13-5.el6sat.x86_64 (/libapreq2-2.13-5.el6sat.x86_64)
perl-RPM2-0.68-38.el6sat.x86_64 from /perl-RPM2-0.68-38.el6sat.x86_64 has depsolving problems
  --> Missing Dependency: librpm.so.1()(64bit) is needed by package perl-RPM2-0.68-38.el6sat.x86_64 (/perl-RPM2-0.68-38.el6sat.x86_64)
perl-List-MoreUtils-0.22-10.el6.x86_64 from /perl-List-MoreUtils-0.22-10.el6.x86_64 has depsolving problems

Environment

  • Red Hat Network (RHN) Satellite

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In