Cannot build our application on Openshift Jenkins when using custom gear size in Openshift Online with Dedicated Node Support

Solution Unverified - Updated -

Issue

We have been trying to enable a Jenkins gear on our dedicated openshift but it seems that Jenkins doesn’t work with large gear sizes or something. We get the log error

~~~
Caused by: com.openshift.internal.client.httpclient.InternalServerErrorException: {"api_version":1.2,"data":null,"messages":[{"exit_code":140,"field":null,"index":null,"severity":"error","text":"Unable to complete the requested operation due to: No nodes available for the specified gear size/region combination. Please try again and contact support if the issue persists. \nReference ID:
~~~

Steps to reproduce:

1) Setup a multi-nodes env, default region is region_1 that is added large profile node.region_2 is added small profile node.
2) Create jenkins app in region_2
3) Create app with jenkins client in region_2
4) Check slave configure,default builder size is small,region field has beed added.And it's empty for default region.
5) Don't change region field,trigger build will fail with error "No nodes available"
6) Modify region field to region_2 with small gear size.Trigger build will succeed

Environment

Openshift Online Dedicated Node Support

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In