When associating virtual machine with compute resource it fails with 'some UUID was not found' message ?

Solution Unverified - Updated -

Issue

  • Unable to associate virtual machines with compute resource, it fails with 'some UUID was not found' message ?
  • Registered the virtual system running on ESX on Satellite, configured virt-who on it to report guest and host mappings. On Content Hosts page on opening virtual machine profile can see that it has been mapped to ESX hypervisor registered using virt-who. Now added a Compute Resource on Satellite from Infrastructure-->Compute Resource tab of VCenter which has this virtual machine. Could load virtual machines, can see data centers of this compute resource so there are no issues when loading any information from VCenter to Satellite. After this selected this compute resource and clicked on 'Associate VMs' and it throws error as below,
Error
50345a2c-b354-d10f-369b-8edf64354e06 was not found

Full Trace:

Fog::Compute::Vsphere::NotFound
50345a2c-b354-d10f-369b-8edf64354e06 was not found
app/models/compute_resources/foreman/model/vmware.rb:377:in `associated_host'
app/controllers/compute_resources_controller.rb:49:in `block in associate'
app/controllers/compute_resources_controller.rb:47:in `associate'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'

Environment

  • Red Hat Satellite 6.0

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In