Satellite 6 disconnected ISO install failing with ruby dependency errors

Solution Unverified - Updated -

Issue

  • I mounted the Satellite 6 ISO on loopback and ran the install_packages script in my disconnected environment and got the following dependency errors:
Error: Package: ruby193-rubygem-deface-0.7.2-7.el6sat.noarch (SAT6media)
           Requires: ruby193-rubygems
Error: Package: ruby193-rubygem-apipie-params-0.0.3-2.el6sat.noarch (SAT6media)
           Requires: ruby193-rubygem(activesupport)
Error: Package: ruby193-rubygem-strong_parameters-0.2.1-11.el6sat.noarch (SAT6media)
           Requires: ruby193-rubygem(railties) >= 3.0
Error: Package: ruby193-rubygem-unf_ext-0.0.6-5.el6sat.x86_64 (SAT6media)
           Requires: ruby193-rubygems
Error: Package: ruby193-rubygem-multi_json-1.8.2-4.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby(abi) = 1.9.1
Error: Package: ruby193-rubygem-hooks-0.2.2-7.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby(abi) = 1.9.1
Error: Package: ruby193-rubygem-foreigner-1.4.2-1.el6sat.noarch (SAT6media)
           Requires: ruby193-rubygem(activerecord) >= 3.0.0
Error: Package: ruby193-rubygem-deep_cloneable-1.6.0-3.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby(rubygems)
Error: Package: ruby193-rubygem-strong_parameters-0.2.1-11.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby(abi) = 1.9.1
Error: Package: ruby193-rubygem-commonjs-0.2.6-7.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby
Error: Package: ruby193-rubygem-bootstrap-sass-3.0.3.0-1.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby(rubygems)
Error: Package: ruby193-rubygem-scoped_search-2.7.1-2.el6sat.noarch (SAT6media)
           Requires: ruby193-rubygems
Error: Package: ruby193-rubygem-little-plugger-1.1.3-16.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby(rubygems)
Error: Package: ruby193-rubygem-sprockets-rails-2.0.1-5.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby(abi) = 1.9.1
Error: Package: ruby193-rubygem-angular-rails-templates-0.0.4-5.el6sat.noarch (SAT6media)
           Requires: ruby193-rubygem(railties) >= 3.1
Error: Package: ruby193-rubygem-rbvmomi-1.6.0-3.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby >= 1.8.7
Error: Package: ruby193-rubygem-faraday-0.8.8-2.el6sat.noarch (SAT6media)
           Requires: ruby193-ruby(rubygems)
Error while executing command: 'yum install -y katello'

Environment

  • Red Hat Satellite 6.0
  • Disconnected Environment

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In