Why does Satellite 6 installation fail with puppet or ruby193-* dependencies ?

Updated 2014-09-12T22:58:19+00:00

Issue

  • The puppet package is missing from the Satellite 6 repositories.
  • When installing the katello package for Red Hat Satellite 6, yum fails with the error below
# yum install katello
--> Finished Dependency Resolution
Error: Package: rubygem-kafo-0.5.5-6.el6sat.noarch (rhel-server-6-satellite-6-beta-rpms)
           Requires: puppet
Error: Package: rubygem-kafo_parsers-0.0.2-4.el6sat.noarch (rhel-server-6-satellite-6-beta-rpms)
           Requires: puppet
Error: Package: pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch (rhel-server-6-satellite-6-beta-rpms)
           Requires: puppet >= 2.7

OR

--> Finished Dependency Resolution
Error: Package: ruby193-rubygem-foreigner-1.4.2-1.el6sat.noarch (rhel-server-6-satellite-6-beta-rpms)
           Requires: ruby193-ruby
Error: Package: ruby193-rubygem-will_paginate-3.0.2-10.el6sat.noarch (rhel-server-6-satellite-6-beta-rpms)
           Requires: ruby193-rubygem(activerecord)
Error: Package: ruby193-rubygem-dynflow-0.7.1-1.el6sat.noarch (rhel-server-6-satellite-6-beta-rpms)
           Requires: ruby193-rubygem(activesupport)
Error: Package: ruby193-rubygem-bundler_ext-0.3.0-6.el6sat.noarch (rhel-server-6-satellite-6-beta-rpms)
           Requires: ruby193-rubygem(bundler)

Environment

  • Red Hat Satellite 6.0

Subscriber content preview. For full access to the Red Hat Knowledgebase, please log in.

Not a subscriber? Learn more about the benefits of Red Hat Subscriptions.