Cluster installation failed with error code OCM3016: EIPAddressLimitExceeded

Solution Verified - Updated -

Environment

  • Red Hat OpenShift Service on AWS (ROSA 4)

Issue

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  • Cluster installation failed with error code OCM3016: EIPAddressLimitExceeded
  • Following error log is observed in the install logs:
time="2021-09-20T14:46:06Z" level=error msg="Error: Error creating EIP: AddressLimitExceeded: The maximum number of addresses has been reached."
  • Following OCM messages are displayed:
- EIP address limit exceeded. Clean unused EIP addresses or increase quota and try again.

- "OCM3016": "Insufficient quota available. You need at least 1 available Elastic IP (EIP) address to create your cluster.Check your quota in your AWS account and try again."

Resolution

The cluster's installation is blocked on AWS EIPAddressLimitExceeded error. To resolve this issue, please raise the EIP addresses quota or remove some EIP addresses for the installation to succeed.

  • To verify how many Elastic IP addresses are in use:
    Open the Amazon EC2 console by clicking here and choose Elastic IPs from the navigation pane.

  • To verify your current account limit for Elastic IP addresses:
    You can verify your limit in the Amazon EC2 console:

    • Open the Amazon EC2 console by clicking here.
    • Choose Limits from the navigation pane, and then enter IP in the search field. The limit is EC2-VPC Elastic IPs. If you have access to EC2-Classic, there is an additional limit, EC2-Classic Elastic IPs.

Request an increase

You can request a quota increase for each Region.

To request an increase using the Service Quotas console:

  1. Open the Service Quotas console by clicking here.
  2. From the navigation bar (at the top of the screen), select a Region.
  3. Use the filter field to filter the list by resource name. For example, enter Elastic IPs to locate the quotas for Elastic IPs.
  4. Choose the quota and then click on the “Request quota increase” button.
  5. For Change quota value, enter the new quota value.
  6. Choose Request.
  7. To view any pending or recently resolved requests in the console, choose Dashboard from the navigation pane. For pending requests, choose the status of the request to open the request receipt. The initial status of a request is Pending. After the status changes to Quota requested, you'll see the case number with AWS Support. Choose the case number to open the ticket for your request.

Root Cause

AWS account has default quotas, formerly referred to as limits, for each AWS service. By default, all AWS accounts are limited to five (5) Elastic IP addresses per Region. If the quota for a service exceeds its limit, the customer has to request a quota increase from AWS (Recommended) or they can choose to delete unused objects and reclaim quota.

You can refer our official documentation to know more about required AWS service quotas for installing a ROSA cluster.

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