Cluster installation failed with error code OCM3032: AWSSubnetDoesNotExist
Environment
- Red Hat OpenShift Service on AWS (ROSA 4)
Issue
Disclaimer: Links contained herein to external website(s) are provided for convenience only. Red Hat has not reviewed the links and is not responsible for the content or its availability. The inclusion of any link to an external website does not imply endorsement by Red Hat of the website or their entities, products or services. You agree that Red Hat is not responsible or liable for any loss or expenses that may result due to your use of (or reliance on) the external site or content.
- Cluster installation failed with error code OCM3032: AWSSubnetDoesNotExist.
- Following error message was observed in install logs:
The subnet ID 'subnet-<somesubnetID>' does not exist.
Resolution
The cluster's installation was blocked by an invalid subnet selection error. To resolve this, please check the subnets provided in the platform.aws.subnets parameter during installation.
For more information about AWS VPC/Subnet requirements and optional parameters, please refer Table 3: Optional AWS Parameters and Table 4. Optional AWS parameters in Installation configuration parameters.
Please note that the subnet must be a part of the same machineNetwork[].cidr ranges that you specify. For a standard cluster, specify a public and a private subnet for each availability zone. For a private cluster, specify a private subnet for each availability zone.
Root Cause
This happens when the customer provides the VPC instead of allowing the installation program to create the VPC and the provided subnet is invalid or does not exist.
This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.
Comments