Cluster installation failed with error code OCM3042: AWSEC2QuotaExceeded

Solution Verified - Updated -

Environment

  • Red Hat Openshift Container Platform (OCP 4)
  • Red Hat OpenShift Service on AWS (ROSA 4)
  • Red Hat Openshift Dedicated 4 (OSD 4)

Issue

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  • Cluster installation failed with error code OCM3042: AWSEC2QuotaExceeded
  • Following error log is observed in the install logs:
failed to generate asset.*Platform Quota Check": error(MissingQuota): ec2/<Quota Code> is not available in <AWS-Region> because the required number of resources (32) is more than the limit of 5.

Resolution

The reason behind this error is that you've reached the EC2 quota limit for the region mentioned in the error log. To resolve this, please raise the related quota or free enough resources for the action to succeed.

Option A : Request a quota increase (Recommended)

You can request a quota increase using Service Quotas and AWS Support Center. Increases are not granted immediately. It might take a couple of days for your increase to become effective.

How to request a quota increase?

To request a service quota increase:

  1. Sign in to the AWS Management Console and open the Service Quotas console at here

  2. In the navigation pane, choose AWS services.

  3. Choose an AWS service from the list, or type the name of the service in the search box.

  4. If the quota is adjustable, you can choose the button or the name, and then choose Request quota increase.

  5. For Change quota value, enter the new value. The new value must be greater than the current value.

  6. Choose Request.

To view any pending or recently resolved requests, choose Dashboard from the navigation pane. For pending requests, choose the status of the request to open the request receipt. The initial status of a request is Pending. After the status changes to Quota requested, you'll see the case number with AWS Support. Choose the case number to open the ticket for your request.

After the request is resolved, the Applied quota value for the quota is set to the new value.

Option B: Terminate unused EC2 instances

Note: Before you terminate an instance, verify that you won't lose any data by checking that your Amazon EBS volumes won't be deleted on termination and that you've copied any data that you need from your instance store volumes to persistent storage, such as Amazon EBS or Amazon S3.

To terminate an instance:

  1. Open the Amazon EC2 console be clicking here.

  2. In the navigation pane, choose Instances.

  3. Select the instance, and choose Instance state, Terminate instance.

  4. Choose Terminate when prompted for confirmation.

Root Cause

AWS account has default quotas, formerly referred to as limits, for each AWS service. If the quota for a service exceeds its limit, the customer has to request a quota increase from AWS (Recommended) or they can choose to delete unused objects and reclaim quota.

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