Empty S3 buckets named managed-velero-backups-{$UUID} are present in AWS account

Solution Verified - Updated -

Environment

  • Red Hat OpenShift Service on AWS (ROSA 4)

Issue

In the customer's AWS Account, empty S3 buckets named as managed-velero-backups-{$UUID} are present.

Resolution

These buckets are associated with and created by managed backups and if empty, can be safely deleted. They're likely from historical backups that aren't around any longer. Each bucket has a tag with the ID of the cluster that created the backup.

To delete an empty S3 bucket:

  1. Sign in to the AWS Management Console and open the Amazon S3 console by clicking here.

  2. In the Buckets list, select the option next to the name of the bucket that you want to delete, and then choose Delete at the top of the page.

  3. On the Delete bucket page, confirm that you want to delete the bucket by entering the bucket name into the text field, and then choose Delete bucket.

  4. To verify that you've deleted the bucket, open the Buckets list and enter the name of the bucket that you deleted. If the bucket can't be found, your deletion was successful.

Root Cause

These buckets are created by managed backups that aren't around any longer. Each bucket has a tag with the ID of the cluster that created the backup.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments