Cluster installation failed with error code OCM3013: AWSVPCLimitExceeded
Environment
- Red Hat Openshift Container Platform (OCP 4)
- Red Hat OpenShift Service on AWS (ROSA 4)
- Red Hat Openshift Dedicated 4 (OSD 4)
Issue
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- Cluster installation failed with error code OCM3013: AWSVPCLimitExceeded.
- Following error log is observed in the install logs:
OCM3013 Cluster installation failed. VPC limit exceeded. Clean unused VPCs or increase quota and try again.
Resolution
The reason behind this error is that you've reached the quota for the number of VPCs. You can clean unused VPCs to reclaim quota or request a quota increase from AWS and try again.
Option A : Request a quota increase (Recommended)
You can request a quota increase using Service Quotas and AWS Support Center. Increases are not granted immediately. It might take a couple of days for your increase to become effective.
How to request a quota increase?
To request a service quota increase:
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Sign in to the AWS Management Console and open the Service Quotas console at here
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In the navigation pane, choose AWS services.
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Choose an AWS service from the list, or type the name of the service in the search box.
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If the quota is adjustable, you can choose the button or the name, and then choose Request quota increase.
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For Change quota value, enter the new value. The new value must be greater than the current value.
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Choose Request.
To view any pending or recently resolved requests, choose Dashboard from the navigation pane. For pending requests, choose the status of the request to open the request receipt. The initial status of a request is Pending. After the status changes to Quota requested, you'll see the case number with AWS Support. Choose the case number to open the ticket for your request.
After the request is resolved, the Applied quota value for the quota is set to the new value.
Option B: Clean unused VPC
Requirement:
Before you can delete a VPC, you must first terminate or delete any resources that created a requester-managed network interface in the VPC. For example, you must terminate your EC2 instances and delete your load balancers, NAT gateways, transit gateways, and interface VPC endpoints.
To delete your VPC using the console:
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Open the Amazon EC2 console by clicking here.
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Terminate all instances in the VPC. For more information, see Terminate Your Instance in the Amazon EC2 User Guide for Linux Instances.
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Open the Amazon VPC console by clicking here.
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In the navigation pane, choose Your VPCs.
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Select the VPC to delete and choose Actions, Delete VPC.
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If you have a Site-to-Site VPN connection, select the option to delete it; otherwise, leave it unselected. Choose Delete VPC.
For more information, please refer the official AWS documentation.
Root Cause
AWS account has default quotas, formerly referred to as limits, for each AWS service. If the quota for a service exceeds its limit, the customer has to request a quota increase from AWS (Recommended) or they can choose to delete unused objects and reclaim quota.
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