Cluster installation failed with error code OCM3036: LoadBalancerLimitExceeded

Solution Verified - Updated -

Environment

  • Red Hat Openshift Container Platform (OCP 4)
  • Red Hat OpenShift Service on AWS (ROSA 4)
  • Red Hat Openshift Dedicated 4 (OSD 4)

Issue

Disclaimer: Links contained herein to external website(s) are provided for convenience only. Red Hat has not reviewed the links and is not responsible for the content or its availability. The inclusion of any link to an external website does not imply endorsement by Red Hat of the website or their entities, products or services. You agree that Red Hat is not responsible or liable for any loss or expenses that may result due to your use of (or reliance on) the external site or content.

  • Cluster installation failed with error code OCM3036: LoadBalancerLimitExceeded
  • Following error log is observed in the install logs:
Error syncing load balancer: failed to ensure load balancer: TooManyLoadBalancers: Exceeded quota of account <account_number>

Resolution

The reason behind this error is that you've reached the quota for the number of load balancers. You can clean unused Load Balancers to reclaim quota or request a quota increase from AWS and try again.

Option A : Request a quota increase (Recommended)

You can request a quota increase using Service Quotas and AWS Support Center. Increases are not granted immediately. It might take a couple of days for your increase to become effective.

How to request a quota increase?

To request a service quota increase:

  1. Sign in to the AWS Management Console and open the Service Quotas console at here

  2. In the navigation pane, choose AWS services.

  3. Choose an AWS service from the list, or type the name of the service in the search box.

  4. If the quota is adjustable, you can choose the button or the name, and then choose Request quota increase.

  5. For Change quota value, enter the new value. The new value must be greater than the current value.

  6. Choose Request.

To view any pending or recently resolved requests, choose Dashboard from the navigation pane. For pending requests, choose the status of the request to open the request receipt. The initial status of a request is Pending. After the status changes to Quota requested, you'll see the case number with AWS Support. Choose the case number to open the ticket for your request.

After the request is resolved, the Applied quota value for the quota is set to the new value.

Option B: Clean unused Load Balancers

When you no longer need the load balancer, you can delete it. You can't delete a load balancer if deletion protection is enabled. For more information, see Deletion protection.

To delete a load balancer using the console
  1. If you have a CNAME record for your domain that points to your load balancer, point it to a new location and wait for the DNS change to take effect before deleting your load balancer.

  2. Open the Amazon EC2 console by clicking here.

  3. On the navigation pane, under LOAD BALANCING, choose Load Balancers.

  4. Select the load balancer, and then choose Actions, Delete.

  5. When prompted for confirmation, choose Yes, Delete.

Root Cause

AWS account has default quotas, formerly referred to as limits, for each AWS service. If the quota for a service exceeds its limit, the customer has to request a quota increase from AWS (Recommended) or they can choose to delete unused objects and reclaim quota.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments