Pod fails with "The container could not be located when the pod was deleted. The container used to be Running" error
Issue
- A pod is facing
The container could not be located when the pod was deleted. The container used to be Runningerror. -
The pod is stuck (it could be in
TerminatingorPodInitializingstate) with below error:exitCode: 137 finishedAt: null message: The container could not be located when the pod was deleted. The container used to be Running reason: ContainerStatusUnknown startedAt: null
Environment
- Red Hat OpenShift Container Platform (RHOCP)
- 4
Subscriber exclusive content
A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.