How to register an ARO cluster in OCM

Solution Verified - Updated -

Environment

  • Azure Red Hat OpenShift (ARO)
    • 4
  • OpenShift Managed (Azure)
    • 4
  • Red Hat OpenShift Cluster Manager (OCM)
  • Red Hat Customer Portal

Issue

  • After creating an ARO cluster, it's not shown in the OCM console.
  • Missing Red Hat subscription for ARO.
  • How to provide files to cases from ARO clusters.
  • Attaching files to cases via mail is not possible as per KCS 413463: Cannot attach files to cases via email, how to attach files for ARO support cases?
  • How to access ARO cases through the Red Hat Customer Portal.
  • Cannot see Red Hat Knowledgebase solutions and articles without a Red Hat Account.
  • How to use Insights to identify issues with ARO clusters.
  • Is it possible to use Insights in ARO clusters?

Resolution

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To be able to access to the Red Hat Knowledge Base at https://access.redhat.com/ for viewing solutions and articles linked by Red Hat Support, and to manage ARO cases from the Red Hat Customer Portal, it is needed a Red Hat Account and to register the ARO cluster in OCM.
Any current Red Hat Subscription is associated to a Red Hat Account. In other case, a new Red Hat Account for registering the ARO cluster can be created at https://cloud.redhat.com.

Note: refer to showing data collected by remote health monitoring for additional information about the data collected when the remote health monitoring is configured.

Register an ARO cluster in OCM

With a valid Red Hat account, the steps to register an ARO cluster to OCM are as following:

  1. Login to https://console.redhat.com with the Red Hat account.

  2. Download the pull secret file from https://console.redhat.com/openshift/downloads#tool-pull-secret. That file includes an authentication for cloud.openshift.com associated to the Red Hat account. That authentication is used by OCM.

  3. Follow the official ARO documentation in Add or update the Red Hat pull secret on an ARO 4 cluster to merge the downloaded pull secret (in particular, the cloud.openshift.com) to the ARO pull secret.

    Important: be careful not to overwrite the default ARO cluster pull secret, but merge it as explained in the doc.
    Note: adding/updating the pull secret restarts the nodes gracefully in OCP 4.7.4 and older. In those versions, this will cause the pods to be restarted and scheduled in different nodes. Starting with OCP 4.7.4, the nodes are not restarted after adding/updating the pull secret (refer to the OCP 4.7 release notes for additional information).

  4. It may take several minutes (it could be up to an hour) to have the cluster automatically registered in OCM. It's possible to see the list of clusters associated to the account in the OCM Console.
    Please, check the clusterID within the Cluster Overview section of the OpenShift admin console with the ID of the cluster in OCM to make sure the right cluster is registered.

    Note: if the cluster is still not listed in OCM, check if there are stuck pods preventing the new pull secret to be loaded as shown in the "Diagnostic Steps" section.

  5. The cluster will appear as a 60-day self-supported evaluation cluster. After some time (it may take up to 24 hours), the cluster will be "updated" to an ARO cluster.

Note: If after some time the cluster is not present in OCM, or it's shown as "Stale", refer to OpenShift cluster not present or shown as Stale in OCM.

Please, refer to Registering an ARO cluster to OpenShift Cluster Manager for additional information.

Root Cause

By default, ARO clusters do not come connected to OCM unless the pull secret is configured during the installation. This is to allow customers to specifically opt-in to connections/data sent outside of Azure, which is the case with registering to OCM that enables a telemetry service in ARO.

Registering an ARO cluster to OCM will create a subscription to allow access to cases through the Red Hat Customer Portal, and also access to the Red Hat Knowledge Base at https://access.redhat.com/.

Diagnostic Steps

Check if there are any pod stuck preventing the new pull secret to be loaded:

$ oc get pods -A | grep -v "Running\|Completed"

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