Some of my subscriptions are missing from the Subscription Management Application while creating or updating a Satellite certificate

Solution Verified - Updated -

Environment

  • Red Hat Satellite or Proxy
  • Subscription Management Application on the Red Hat Cusomer Portal

Issue

  • The "Subscription Management Applications" does not allow me to attach Red Hat Proxy and JBoss subscriptions to a Certificate.
  • The RH Proxies are not available in the list of subscriptions so I can not attach a Proxy subscription to a certificate. In reality we have 3 proxy servers in our contract.
  • When I attach any of the JBoss subscriptions to a certificate I am not able to download the certificate. The following error appears "Subscription 2534233 does not have enough entitlements to fulfil request: 64".
  • In practise this means I am not able to retrieve certain channels from the Red Hat Network. When running a satellite-sync some channels appear to be end-of-support.

Resolution

  • Please contact Red Hat Technical support or open a case requesting a refresh of your subscriptions in the Customer Portal

Root Cause

  • Sometimes a refresh is required on the Customer Portal to make sure all subscriptions are visible and can be attached to a Satellite in the Subscription Management Application

Diagnostic Steps

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