Repositories are not available for a registered VM with attached subscription in Customer Portal

Solution Verified - Updated -

Environment

  • Red Hat Enterprise Linux
  • Customer Portal

Issue

  • The RHEL system is registered, attached with a valid subscription but cannot access the repos:
# subscription-manager repos --list
This system has no repositories available through subscriptions.
  • The system is consuming a subscription with a status "Subscription has not begun"
# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name:   90 Day Red Hat Satellite Standard Supported Evaluation
Provides:            Red Hat Satellite 5 Managed DB Beta
                     Red Hat Software Collections (for RHEL Server)
                     Red Hat Satellite 5 Managed DB
                     Red Hat Satellite
                    :
SKU:                 SER0207US
Contract:            12345678
Account:             1234567
Serial:              6074729913106928364
Pool ID:             8a85f98c6100bb0101610134b3e40698
Provides Management: Yes
Active:              False
Quantity Used:       1
Service Level:       Premium
Service Type:        L1-L3
Status Details:      Subscription has not begun  <=====
Subscription Type:   Standard
Starts:              16/01/18
Ends:                16/04/18
System Type:         Physical

Resolution

  • Subscribe the RHEL system with an active subscription.
    Note that future dated subscriptions can be added to the manifest or attach to a registered system but remains inactive until the start date.
  • If in case the subscription attached to the system is active but the status is showing as "Subscription has not begun", check the system time
    and confirm that is correctly set to its timezone/Geo.

Root Cause

  • A future dated subscription is attached which will remain inactive until the starting date.
  • The system time is incorrect making the subscription to be future-dated than the system.

Diagnostic Steps

  • Verify that the system is only registered once (only 1 line of the name is listed/exist) in Subscription Management.
  • Verify that the subscription attach is active.
  • Verify that the system time is correct to the geological location/timezone.

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