VDB version "latest" does not exist in server.log when starting up the second node of my SOA-P EDS cluster

Solution Verified - Updated -

Environment

  • JBoss Enterprise Data Services (EDS) 5.3
  • JBoss Enterprise SOA Platform (SOA-P) 5.3

Issue

  • We have a two node JBoss SOA-P 5.3.0 with EDS-P 5.3.0 cluster. The -ds.xml files and VDB have been deployed. They are configured to use a Password Based Encryption security-domain. I have also added the security domains to the teiid/teiid-jboss-beans.xml Session security domain. The error occurs only on the start up of the second node when the security domain is enabled. This always happens only on the second node to start up no matter which node starts up second.

Resolution

The security domain for the datasources is pinging the VDB, there is no way to stop or change the timing of it. The error message can be ignored.

Root Cause

Customer setup Security Domains to workaround the Connection test [1], several of the Datasources involved connect to an EDS VDB that is deployed on the same servers, the test is occurring before the deployment of the VDB, hence the "VDB doesn't exist" error.

[1] https://access.redhat.com/knowledge/solutions/54980

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