Why there is an Exclamation mark in front of repositories id when running yum on clients registered with Red Hat Satellite 6?

Solution Verified - Updated -

Environment

  • Red Hat Satellite 6.X.
  • Yum

Issue

  • Why there are Exclamation mark in front of pulp repository names on Client system's registered with Red Hat Satellite 6 ?
# yum repolist
Loaded plugins: product-id, search-disabled-repos, subscription-manager
repo id                                                               repo name                                                                     status
!rhel-7-server-extras-rpms/x86_64                                     Red Hat Enterprise Linux 7 Server - Extras (RPMs)                               188
!rhel-7-server-optional-rpms/7Server/x86_64                           Red Hat Enterprise Linux 7 Server - Optional (RPMs)                            8483
!rhel-7-server-rh-common-rpms/7Server/x86_64                          Red Hat Enterprise Linux 7 Server - RH Common (RPMs)                            183
!rhel-7-server-rpms/7Server/x86_64                                    Red Hat Enterprise Linux 7 Server (RPMs)                                      10643
repolist: 19497

Resolution

  • As per yum Man page yum repolist output's first column as ! if the repository has expired metadata.
  • This has been purposefully set to be expired, so it re-downloads the repomd.xml file (which is very small) to always keep repositories up to date.

In order to enforce the resync of repomd.xml file you can run the command below:

# yum clean expire-cache

The command above will enforce to remove the file cachecookies located in /var/cache/yum/x86_64/*/*/. After that, on the next yum repolist the file repomd.xml will be downloaded again.

  • Try setting high value for metadata_expire. For RHEL 7, it's metadata_expire = 86400 in redhat.repo.

Attention Note: The ! mark is not an issue and it's expected when the Content Host is registered on Satellite/Capsule Server.

For more KB articles/solutions related to Red Hat Satellite 6.x Client Subscription Issues, please refer to the Red Hat Satellite Consolidated Troubleshooting Article for Red Hat Satellite 6.x Client Subscription Issues

Root Cause

  • When Content view's are promoted to a newer version with changes,the clients are not able to see the changes unless a cache on the client is manually cleared or is regenerated by yum after a set interval of time period,so to spare the time required for cache regeneration on client end yum would try to fetch cache on each run.
  • Component
  • yum

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