Task metadata (Comment) being improperly stored in I18NText database table in BPM Suite 6.x

Solution Verified - Updated -

Environment

  • Red Hat BPM Suite (BPMS) 6.0.x, 6.1.x

Issue

The metadata about a user task is stored improperly in database. When setting a data to Comment property in Extra properties for a user task in business central, it stores the same text for subject and description fields in I18NText table after starting that task.

By using Rest task query, it is possible to see that both fields are populated with the same data set in Comment property:

// Rest Query
http://localhost:8080/business-central/rest/task/12
// Output
<task><id>12</id><priority>0</priority><name><id>35</id><text>HT1 </text><lang>en-UK</lang></name><subject><id>36</id><text>summer</text><lang>en-UK</lang></subject><description><id>34</id><text>summer</text><lang>en-UK</lang></description>...

There don’t seem to be fields called description or subject in the business central for User Tasks Extra Properties, so that it could be stored properly in database.

Resolution

From BPM Suite 6.2 on it has been modified. The Comment field was renamed to Subject and now there is a new property called Description, then you can set them separately.

Root Cause

This is how it was designer to work in previous versions. There is only one property (Comment) in the process, this is translated to both Description and Subject in the WS_HT model.

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