Unable to delete a "Data Provider" in Dashbuilder for JBoss BPM Suite 6.0.x

Solution Unverified - Updated -

Environment

  • Red Hat JBoss Business Process Management Suite (BPM Suite) 6.x

Issue

It is not possible to delete a Data Provider, the following message is thrown:

Cannot delete the data provider because it is being used by 7 KPI(s)

How to delete a Data Provider from Dashbuilder?

Resolution

It will probably be fixed in BPM Suite 6.1.0. However, a workaround exists. If you need to delete a data provider (i.e. jBPM Count Process) apply the following steps:

  1. Go to Showcase workspace -> Data providers page with the intention to delete jBPM Count Process - it's impossible to delete it now, because it's used by 1 KPI;
  2. The one KPI that uses this data provider is in jBPM Dashboard workspace - it's KPI Process instances by status;
  3. Go to General Options and expand Workspaces -> jBPMS Dashboard -> Panel Instances and delete the Process instances by status;
  4. Go to General Options and expand Workspaces -> Showcase -> Panel Instances and delete the Process instances by status;

Root Cause

A BZ1116104 was raised to fix it in a future version.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments