yum update error repomd.xml

Latest response

Hi,
my system is Red Hat Enterprise Linux Server release 6.5 (Santiago)
Linux srvvorelv01.avio.net 2.6.32-431.el6.x86_64 #1 SMP Sun Nov 10 22:19:54 EST 2013 x86_64 x86_64 x86_64 GNU/Linux

yum update
Loaded plugins: refresh-packagekit, rhnplugin, security
This system is receiving updates from ULN.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-x86_64-server-6. Please verify its path and try again

Can you help me

thanks

Responses

Riccardo,

ULN suggests that this is for Unreakable Linux? Are you just attempting to get Oracle components from ULN? or all updates etc. as well?

Are you able to browse to the repository URL in a browser?
Does your server have access to the Internet?

I have more details:
on the server there are more active repository.
If I go on the Redhat portal and I disable the channel base redhat rhel-x86_64-server-6 then I can install packages
but
If I go on the Redhat portal and I enable basic channel rhel-x86_64-server-6 then I get the error

yum install wireshark
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from ULN.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-x86_64-server-6. Please verify its path and try again

thanks

What ULN repository are you subscribing the server to?

My approach would be to remove the ULN repository and confirm that the rhel-x86_64-server-6 repository works correctly from RHN.

Then I would ensure that you only add the specific ULN repository that has the packages that you need (what do you need from ULN? asmlib?)

Ok, I have removed ULN from /etc/yum.repos.d but nothing

[root@srvvorelv01 yum.repos.d]# yum install wireshark
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from ULN.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-x86_64-server-6. Please verify its path and try again

What is the repo stanza for rhel-x86_64-server-6? This appears as if you are registered still with the Oracle update server.. so my guess is that you need to look there. I think that due to the line below

This system is receiving updates from ULN.

It sounds like your repomd.xml file has either not been created (or is not current).

This is a daily job (so it may have resolved itself by now ;-) but you can force it with the following:

http://unixrevolution.blogspot.com/2013/07/rhn-satellite-server-spacewalk.html

right, I haven't repomd.xml on my server.
I try the guide, but on my serve there isn't satellite-sync command

thanks

I apologize - I should have mentioned that this was required on the Satellite server (not the client).

After reviewing the thread I don't see a reference to Satellite. Are you running a Satellite Server in your environment?

Like I had mentioned, this job runs daily (should anyhow) - have you tried running the following today:

yum clean all
yum repolist
yum list

there isn't Satellite Server.

[root@srvvorelv01 rhsm]# yum clean all
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Cleaning repos: rhel-x86_64-server-6
Cleaning up Everything
[root@srvvorelv01 rhsm]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from ULN.
repo id repo name status
rhel-x86_64-server-6 Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) 0
repolist: 0
[root@srvvorelv01 rhsm]# yum list
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from ULN.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-x86_64-server-6. Please verify its path and try again

I guess we forgot to ask the most basic question to start: Is your host registered to RHN (or Satellite)? You already let us know that it is not registered to a Satellite.

Like PixelDrift had mentioned, it appears that you are registered to Oracle's Repos (or have at least added the repo's separately)

ls -l /etc/yum.repos.d/

If you have a subscription with Red Hat, I recommend reviewing the following:
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/entitlements.html

Here is a doc on how to re-register your system:
https://access.redhat.com/site/solutions/8036

I am not knowledgable enough with Subscriptions/Entitlements to know exactly what to ask, but I believe the docs I provided should get you going again.

ls /etc/yum.repos.d/
repo.disabled rhel-source.repo.

I already re-registered but nothing

I suspect your server may be registered to ULN using the rhnplugin, which may explain why you don't see any repositories in /etc/yum.repos.d.

The fact you are still receiving this message "This system is receiving updates from ULN." means you need to try and remove the registration from ULN. Can you login to the ULN interface and remove the host manually from there?

What method did you use to register the server with ULN originally? Did you follow some Oracle provided instructions?

yes, also I think so. the server is used by a employee then I do not know which command has given.
is there a way to reset yum?

thanks

I'm having a similar problem to this but I'm on RHEL 5 and I've never subscribed to the Oracle repos.

yum repolist

Loading "product-id" plugin
Not loading "rhnplugin" plugin, as it is disabled
Loading "security" plugin
Loading "subscription-manager" plugin
Running "config" handler for "security" plugin
Running "config" handler for "subscription-manager" plugin
Updating Subscription Management repositories.
This system is receiving updates from Red Hat Subscription Management.
Config time: 1.481
Yum Version: 3.2.22
COMMAND: yum repolist
Installroot: /
https://cdn.redhat.com/content/dist/rhel/server/5/5/x86_64/cf-tools/1/os/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-5-server-cf-tools-1-rpms. Please verify its path and try again

Hi there. This is an older thread, so you might get better results if you start a new topic with your details for this issue.

Edit the epel.repo file and amend the 4th line from https to http. done, sorted ;-)
You're welcome

have you checked the permissions on the repomd.xml file? check the full path to this file. Check all the permissions along the way as you go. The directory holding the packages, the repodata directory and the repomd.xml .

I usually set directories to 755 , repodata 755 , files inside repodata which include repomd.xml 644.

Also check your entries in /etc/yum.repos.d. Make sure the client is configured correctly with the correct path.

Thanks

Arrey

Hey, good day

I have the same problem and I've done all the suggestion, but still the same repomd.xml message , with the yum update:

Loaded plugins: rhnplugin, security
This system is receiving updates from RHN Classic or RHN Satellite.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-x86_64-server-6. Please verify its path and try again

What could be the reason?

Can you can post the contents of your repository file?

We can work from there.

How can I do that, please?

Repo files are stored in
/etc/yum.repos.d/

"Error: Cannot retrieve repository metadata (repomd.xml) for repository:
rhel-x86_64-server-6. Please verify its path and try again"

That typically indicates that there is an issue with DNS, or you cannot reach the server that it is attempting to contact (i.e. port 80/443 is blocked).

Are you using RHN Classic or Subscription Manager with your host?

Please run this and provide the output

yum repolist

Hello,

here the result

Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
repo id repo name status
redhat-rhn-satellite-5.6-server-x86_64-6 Red Hat Satellite (v5.6 for Server v6 AMD64 / Intel64) 473
rhel-x86_64-server-6 Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) 14,213
rhel-x86_64-server-optional-6 RHEL Server Optional (v. 6 64-bit x86_64) 8,044
repolist: 22,730

Did you get this result after setting enabled=1 on local.repo?

No, I did it now, is it in my last post

Go to /etc/yum.repos.d

Post the contents of any files in this directory.

here the contents of epel.repo.rpmsave

[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch

baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch

mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 6 - $basearch - Debug

baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch/debug

mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 6 - $basearch - Source

baseurl=http://download.fedoraproject.org/pub/epel/6/SRPMS

mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1
~
~
**contents of local.repo_

[local1]
name=local1
baseurl=http://10.1.43.37/satellite
enabled=0
gpgcheck=0

TIP: When including code/output in your reply, you should enclose the output with 3 x tilde's ~

~~~
code here
~~~

Regarding your host. Something modified your repo files. An "active" repo should end with .repo.

Judging by the fact that you have the repo for Satellite (from one of your other responses), I will assume you are building a Satellite server. If this is just a test Satellite, EPEL might be OK. Otherwise, if this, in fact, a Satellite Server and you actually hope to use this long term - my recommendation is that you may want to consider starting over. The Satellite installation is rather specific about a few particular items. One of which is the packages and package groups that are available to your system. (They recommend that you build your system only using @Base and the bare minimum packages, then when you run the Satellite installation it will ask you if you want to have the installer fix the dependencies).

The Base OS repos are not in /etc/yum.repos.d/* - but are configured elsewhere when you subscribe your system to the Red Hat Network (using classic or subscription manager). I do not know specifically which files contain the attach repos - but I will dig around to get you an answer.

My biggest question at this point: what are you trying to accomplish with this host? I want to make sure that we can offer the best advice based on what you are trying to do.

Hi,

Thanks for the answer,

My problem here is because I've subscribed a new server and when I tried to do the yum install, the message "Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-x86_64-server-6. Please verify its path and try again"

Thanks

Ah - I apologize, I did not even realize that you were not the original owner of this thread (I just figured that out).

And I apologize again as I still don't understand what you are trying to do. It appears you are using RHN Classic (which is fine). I'll try to reread the thread and think about the issue again.

If this is a production issue, I recommend opening a case with Red Hat
https://access.redhat.com/support/cases/new/

All of us here at the Customer Portal (or almost all of us) are volunteers that try to help folks, but we have our limitations ;-)

Looks like all your repositories are turned off .

enabled=0 means they are off.

for the local.repo ,

set enabled=0 to enabled=1

Then do

yum clean all

yum repolist

Then let the community know what the outcome is.

Here are the results after I did yum repolist

Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
redhat-rhn-satellite-5.6-server-x86_64-6 | 1.6 kB 00:00
redhat-rhn-satellite-5.6-server-x86_64-6/primary | 169 kB 00:00
redhat-rhn-satellite-5.6-server-x86_64-6 473/473
rhel-x86_64-server-6 | 1.8 kB 00:00
rhel-x86_64-server-6/primary | 19 MB 00:06
rhel-x86_64-server-6 14215/14215
rhel-x86_64-server-optional-6 | 1.8 kB 00:00
rhel-x86_64-server-optional-6/primary | 1.9 MB 00:00
rhel-x86_64-server-optional-6 8044/8044
repo id repo name status
redhat-rhn-satellite-5.6-server-x86_64-6 Red Hat Satellite (v5.6 for Server v6 AMD64 / Intel64) 473
rhel-x86_64-server-6 Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) 14,215
rhel-x86_64-server-optional-6 RHEL Server Optional (v. 6 64-bit x86_64) 8,044
repolist: 22,732

Follow the advice of
James Radtke

From the looks of it, you no longer have issues. But if I were, I will take into consideration what James Radtke is talking about.

Consejo,

Do you use RHN or a local Satellite?

I have had this a couple of times, using https to connect to RHN or a local Satellite

So can you try to change the following line in /etc/sysconfig/rhn/up2date
~~serverURL=https://xmlrpc.rhn.redhat.com/XMLRPC
in
~~serverURL=http://xmlrpc.rhn.redhat.com/XMLRPC

For a local Satellite the URL will differ.

After the change try your yum commands once more and let us know the result.

Kind regards,

Jan Gerrit Kootstra

Thank you very much.

I've changed what you asked, and it work.

Now I can make the yum updates.

Regards

for local repository

cd [your repository base dir]
createrepo .      #read packages and create repomod.xml

hi I want to update my liabaio package but can't [root@usndlsdcs2vua17 pluginconf.d]# yum update libaio Loaded plugins: search-disabled-repos, security, subscription-manager This system is not registered with an entitlement server. You can use subscription-manager to register. Setting up Update Process ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/repodata/repomd.xml: [Errno 12] Timeout on ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/repodata/repomd.xml: (28, 'connect() timed out!') Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-source. Please verify its path and try again [root@usndlsdcs2vua17 pluginconf.d]#