CLI Command - Error handling command: deploy

Latest response

Hi everyone,
I am trying to use Jython Script to deploy '*.ear' file on JBOSS EAP 6 Cluster running in Domain Mode.
This Jython Script uses CLI class to connect with remote EAP Domain Controller and also for the deployment.
Following is the CLI method that I am using to deploy the ear file.

deploy ...\target\XyzEAR.ear --server-groups=abc-df-efg

For some reason, this file argument throws an error message:
"java.lang.IllegalArgumentException:
java.lang.IllegalArgumentException:
Error handling command:
deploy -f ... arget\XyzEAR.ear --server-groups=abc-df-efg"
there were lot of blank spaces in the file argument in the displayed message.

The same method works fine with no error if I put the file name argument like "C:\target\XyzEAR.ear".

Is there any way to pass a longer file argument to 'deploy' method?

Responses

Piyush,

Can you clarify the exact command you are running? are you placing the '...' in the filename parameter, or is that the output after running the command?

Have you attempted to quote the file path?

Thanks for the timely response!
Yes, I have tried quoting the file path and have encountered the same exception.
Following is the exact commands that I have tried :
1] "deploy C:\Deployment\CompanyEAR.ear --server-groups=abc-ha-dev"
Result-> SUCCESS

2] "deploy C:\SVN\JbossServerRelease\Entity\target\CompanyEAR.ear --server-groups=abc-ha-dev"
Result-> Failed with the aforementioned exception.

Hope that helps!

Can you also elaborate that where is application deployment directory ? if successfully deployment done then where is application take a directory path where I check physical location of application plz