Yum update error on RedHat 9.4 with active suscription

Posted on

Hi, I have a newly installed server Red Hat 9.4 on a vm machine and when I do yum update it tells me the following

[root@db03-engine-pre yum.repos.d]# yum update
Updating Subscription Management repositories.
Red Hat Enterprise Linux 9 for x86_64 - AppStream (RPMs) 563 B/s | 462 B 00:00
Errors during downloading metadata for repository 'rhel-9-for-x86_64-appstream-rpms':
- Status code: 403 for https://cdn.redhat.com/content/dist/rhel9//x86_64/appstream/os/repodata/repomd.xml (IP:
Error: Failed to download metadata for repo 'rhel-9-for-x86_64-appstream-rpms': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

I have tried to do this but the problem continues.

subscription-manager remove --all
subscription-manager unregister
subscription-manager clean
dnf clean all
rm -rf /var/cache/yum/*
subscription-manager register
subscription-manager attach --auto

[root@db03-engine-pre yum.repos.d]# subscription-manager list
Installed Product Status
Product Name: Red Hat Enterprise Linux for x86_64
Product ID: 479
Version: 9.4
Arch: x86_64
Status: Subscribed
Status Details:
Starts: 03/01/2024
Ends: 06/17/2024

[root@db03-engine-pre yum.repos.d]#

Thanks for support.