About displaying X apps on a machine with a CUI server selected in the base environment

Posted on


I installed the base environment as a non-graphical server, assuming that I would use the remote machine with CUI.

However, since I needed to start a browser to install certain services, I specified only firefox in dnf and installed it with related objects.

Since GUI is not usually needed, I did not install window managers such as X-Window or gnome. Let's call this host rmt01 for now.

Separately from this, I prepared an X-Window server lcl01 as a local machine. Both are RHEL9.4 with only standard packages.

Since rmt01 is also an ssh server, I enabled "X11Forwarding yes" in /etc/ssh/sshd_config and restarted sshd.service.

I started TERMINAL on lcl01,
(1) logged in to rmt01 while applying XForwarding with ssh -X rmt01, (2) specified export DISPLAY=:0.0, and (3) tried to start the default installed firefox, but (4) the message "Error: cannot open display: :0.0" was displayed and firefox could not be started. (5) I tried various settings for (2), such as :10.0, localhost:0.0, localhost:10.0, unix:0.0, unix:10.0, but the result was the same. I tried looking for error records in X-related log files, (6) found nothing when I executed find for "Xorg*log" on the rmt01 side, and (7) checked "/var/lib/gdm/.local/share/xorg/Xorg.0.log" found on the lcl01 side, but there was no such record. Why can't I start Firefox on a remote computer?