Cannot authenticate to Red Hat registries using my pull secret

Posted on

After I set up crc locally, I was facing issues when trying to deploy anything that would require an image pull from
So, I tried the same with podman, using the pull secret file for authentication:

$ podman pull --authfile ./pull-secret.txt
Trying to pull
Error: initializing source docker:// unable to retrieve auth token: invalid username/password: unauthorized: Please login to the Red Hat Registry using your Customer Portal credentials. Further instructions can be found here:

Then I tried the same, using a pull secret from another account I have:

$ podman pull --authfile ./acn-pull-secret.txt
Trying to pull
Getting image source signatures
Copying blob 70de3d8fc2c6 skipped: already exists
Copying config 62ac1f7ef5 done
Writing manifest to image destination
Storing signatures

Clearly, there's something wrong with the first pull secret. I tried to regenerate the pull secret, following the procedure in but with same result.

Please advise.