Re-installed rhev-m, now I can't connect...

Latest response

Hello,

 

I have re-installed rhev-m while trying to solve a different problem, but now I can't connect.

 

I ran rhevm-cleanup, then rhevm-setup, repeated my settings of before that were previously successfull. I had to change the time-zone temporarily to get the certificate to be created successfully, again as before.

 

Things seemed to go ok until I rebooted the box running rhev-m, and now I can't connect to rhev-m anymore. When I open up IE on my browser, having cleared the cache and installed the CA etc, I can get to the RHEV menu (https://rhevman.mydomain:8443) but when I click on the Administrator link (https://rhevman.mydomain:8443/RHEVManager) I now get an error:

 

HTTP Status 404 - /RHEVManager

 

type Status report

 

message /RHEVManager

 

description The requested resource (/RHEVManager) is not available.

 

JBoss Web/2.1.12.GA-patch-01

 

I've tried turning off iptables in case the problem is about blocked ports, and despite the fact that rhevm-setup overides iptables anyway, but this does not help. I have tried restarting jboss (service jboss restart) and restarting rhevm itself (service rhevm restart) but without success, both result "unrecognized service".

 

Any suggestions welcome.

Responses

Please watch the rhevm.log file (unde /var/log/rhevm) and restart jbossas - any errors?

Thanks a lot Dan, I suspected it was just a matter of restarting jboss.... and it was;

service jbossas restart worked. :-)

 

Was the service down before?

I think so...

 

[root@rhevman]# service jbossas restart
Stopping jbossas: [ OK ]
[FAILED]
Process already running
[root@rhevman]# service jbossas stop
[root@rhevman]# [FAILED]
[root@rhevman]#
[root@rhevman]# service jbossas start
Starting jbossas: [ OK ]
[root@rhevman]#

 

 

Situation unclear. After all that though I was then able to connect via IE.