Upgrade to RHEL 6.2 kernel-2.6.32-220.7.1.el6.x86_64 causes kernel panic on boot

Latest response

Running RHEL 6 on a new, vanilla Dell T1600 workstation. Nothing attached but keyboard and monitor. Latest Dell BIOS (A10).

 

Installed RHEL from distribution DVDs; no problems. Then did a "yum update"; no other changes, no other downloads. System now panics immediately on booting with the yum-supplied kernel-2..6.32-220.7.1.el6.x86_64 and is immediately unresponsive to any keyboard input - have to power off to restart.

 

Last few lines of the trace/dump on the console are below - I can't see any more than this and as a newbie, not sure how to direct the crash output somewhere else (file, COMx, etc) to see it all. Suggestions welcomed....

 

Superficially this is similar to the output described in https://bugzilla.redhat.com/show_bug.cgi?id=770228 - but since that was only a warning message, not a crash, I'm not sure it applies here. (I have tried "pcie_aspm=off" as mentioned in other postings as a possible solution - no joy.)

 

Again, suggestions welcomed. I can run on the stock kernel (2.6.32-71.el6.x86_64) for now but would rather be up-to-date.

 

David

 

 [<ffffffffa01a2000>] ? nouveau_init+0x0/0x51 [nouveau]
 [<ffffffffa008106a>] drm_pci_init+0x11a/0x130 [drm]
 [<ffffffffa01a2000>] ? nouveau_init+0x0/0x51 [nouveau]
 [<ffffffffa01a2000>] ? nouveau_init+0x0/0x51 [nouveau]
 [<ffffffffa01a204f>] nouveau_init+0x4f/0x51 [nouveau]
 [<ffffffff8100204c>] do_one_initcall+0x3c/0x1d0
 [<ffffffff810af5f1>] sys_init_module+0xe1/0x250
 [<ffffffff8100b0f2>] system_call_fastpath+0x16/0x1b

Responses

kernel-2.6.32-220.4.1.el6_x86_64 panics / crashes on boot in the same spot with same output; ditto for 2.6.32-220.2.1 and 2.6.32-131.x.

 

So it's something across all of these, which makes me think it's unique to my situation as others would be reporting this with so many kernel versions involved.

Removing the NVIDIA Quadro 600 video card (hadn't known it was in the system) and reverting to the stock Dell T1600 onboard video solved the problem.

 

Needless to say, I suspect it's NVIDIA's drivers that are the issue, not anything related to the kernel.

 

We  now return you to your regularly schedule program.

I also faced the same problem. But finally it is working fine for me. My mechine was not connected properly with RHN. In the system tab I did not find my device.

 

Right after that I connected my new device by using rhn_register. then I update my kernel and working fine.

 

I dont know the what happend with my first mechine, which gave a panic after booting. My suggestion is connect properly with rhn. In my first device it was not connected properly although it was allowing me to update my kernel.

 

Please suggest me if I am wrong.

In my case it was a "broken" download.