RHEV - HA option not being transferred to template

Latest response

Hello

 

I have raised a RHN support ticket for the below but thought I'd open it up to a wider audience in case anyone is experiencing the same...... 

 

We have noticed that the "Highly Available" option does not transfer when creating a template from a guest.

 

1. Create a template from an existing VM with "Highly Available" option enabled (Yes)

2. Template details show "Highly Available" disabled (No)

3. Create a VM from the template and "Highly Available" will be disabled

 

Moreover, you are unable to edit the template to enable the "Highly Available" option.

 

Expected result :- All options should transfer between VM and the template created from it.

User should be able to edit template options.

 

Cheers

Responses

Do the VMs created from the template turn out to be HA?

Nope.  As per step 3.

Thanks for the report Richard,

 

I'll run a quick reproducer internally, and file a BZ for this. 

Dan,  I guess this could be by design but I though the whole idea of a template was to enable you to thump out VM's superfast without having to edit the subsequent guest config.

The fact that you can't edit the template config is frustrating too.

Top stuff. Thanks Dan

Just tested this internally:

1. Template created from an HA VM loses the HA flag and settings - will file a BZ

2. Template can be edited, and HA properties can be changed

3. New VM created from a template that has HA set up, has the same settings

 

So 2 and 3 I couldn't reproduce, seem to be woring just fine. What RHEV-M versions are you using?

Dan, I have a bit more information for you.

 

The steps taken were carried out via the Admin portal as admin user. 

If I login as a PowerUser, I'm then able to edit the template config including HA. Any subsequent VM's created from that template carry over the HA config correctly.

The issue appears to be with the Admin portal and/or the default admin user.

 

I shall update the RHN ticket accordingly.

 

Thanks again

I did it through the webadmin portal, using the admin@internal user. Behaviour in the Admin portal (WPF) should be the same. Haven't touched the poweruser portal at all

RHEV-M 3.0.2_0001-2.el6

 

I can confirm that upon hitting the Edit button on the selected template I am presented with the "Edit Template" panel. All the fields are empty , except for Memory Size (256M) and Operating System (Unassigned) which must be default values. Same goes for the other tabs.

 

I am logged into the Admin Portal as user admin.

Blast! Perhaps my template is up the swanny.

I'll create another and will report back with results.

Thanks for your time and patience.

First of all, please update the RHEv-M build to latest, because we might simply be uncovering a bug that has already been fixed.

To update RHEV-M, first run `yum update rhevm-setup -y` and afterwards run `rhevm-upgrade`

 

Lets get you up to date first, and then see if the issue persists

just tried in the poweruser portal - works just as well as everywhere else. I posted above about getting your RHEv-M up to date, so lets do that first.

 

BTW, I kinda left it out, but is the VM a desktop or a server, (since HA is a server feature)?

Hello again Dan

 

Apologies for the lack of feedback on this one.

 

Since we last spoke I built a fresh RHEV-M instance using v3.0.3_0001-3.

I'm getting the same results. That being ....

 

From Admin portal as admin/internal do :-

 

1. Create a template from an existing VM with "Highly Available" option enabled (Yes)

2. Template details show "Highly Available" disabled (No)

3. Create a VM from the template and "Highly Available" will be disabled

 

Still unable to edit the template to enable the "Highly Available" option.

However, from the User portal I'm able to edit all the template options including "Highly Available".

This is with the VM built as a server , as opposed to desktop.

 

Regards

Dan

 

Did you manage to file a BZ for step1 like you mentioned ? 

Related support case 00619438