Help connecting to a repository

Latest response

This message is going to show a very low level of understanding of Linux. Sorry, I'm stuck with the responsibilty for a task that our Linux expert should perform, but he's out of the office.

 

I need to install a copy of PHP 5.2.17 or later on a new RHEL server. A suitable version does not appear to be available in Red Hat's repository.

 

I found 5.2.17 in the IUS Community Project's repository (http://www.iuscommunity.org/), but I can't get the Package Manager to connect to it. The site's "Getting Started" page says that the repository address is http://dl.iuscommunity.org/pub/ius, but when I try to define a repository at that address, Package Manager says "Unable to retrieve software information. This could be caused by not having a network connection available." I've tried a couple of the repository's mirrors with the same result.

 

The computer has no trouble connecting to the predefined RHEL repositories, so the network connection is not the problem. It's not clear what the problem is.

 

Part of this may have to do with yum. The repository's instructions say "Please be sure that you are using yum > 3.2.26, or RHEL’s version 3.2.22-23." I gather from other sources that RHEL's "Package Manager" is actually yum, but its Help/About box doesn't say so, and doesn't say what version it is.

 

The repository's instructions also say some stuff about installing a package named ius-release, which is supposed to "configure your system to use the... repositories, as well as installs the GPG keys necessary to validate signed packages of both." I don't think that's the immediate problem because there's no way I can install ius-release if I can't connect to the repository in the first place, but I don't understand what this package is supposed to do, so I can't be sure.

 

Any advice is welcome!

Responses

Hi Jonathan,

 

I see the latest version of PHP on Red Hat Network for RHEL 6.2 is:

php-5.3.3-3.el6_1.3.x86_64.rpm

 

I see the latest version of PHP on Red Hat Network for RHEL 5.7 is:

php-5.1.6-27.el5_5.3.x86_64.rpm

 

Are you running RHEL 5 or 6? You can issue the following command to find out what version of RHEL you are running from command line (Terminal):

 

cat /etc/redhat-release

 

Keep us posted, and good luck!

 

Andrius.

I hope eu get the updated PHP version.

Try this repository ...:-)

 

# rpm --import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka
# vim /etc/yum.repos.d/utterramblings.repo &
[utterramblings]
name=Jason's Utter Ramblings Repo
baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

 

Please let me know. I tried it a year back.

 

Thanks

Shyfur

Shyfur,

 

Thanks for sharing this!

 

Just a note that installing upstream (or out-of-box) packages is unsupported by Red Hat. Any issues found with an out-of-box package should be raised with the respective community.

 

You probably already knew this, but just wanted to remind you. :-)

 

Thanks again!

 

Andrius.

Our RHEL uis version 5.

 

Our Linux person is back at work today, so I've turned this task over to him. Thanks for your assistance.