RHEV Hypervisor registration with RHEV Manager

Latest response
  • RHEV-M won't add RHEV-H 6.2b hosts out of the box.  The RHEV-M message is "install failed.  Consult logs for details" -- although it doesn't specify which logs, and I've been unable to find anything useful on the RHEV-M box.
  • RHEV-H 6.2b won't register with RHEV-M 3.0b out of the box.  It tries to get a bunch of things from /var/www/html on the -M box, which fails, as that dir is empty.  Copying the files from /var/lib/jbossas/server/rhevm-slimmed/deploy/ROOT.war/ helps, but the SSL negotion still fails.
  • Even when the above SSL error is fixed, it's still impossible to register the host to RHEV-M as it tries to call /RHEVManagerWeb

Responses

It looks like you are trying to add a RHEV Hypervisor using the 'New' button and not the 'Approve' 

 

Can it be the case?

Both options have issues.

 

Steps that were required to get the host to add itself to the management platform, so it can be authorised:

 

1) copy all files (except ca.crt) from /var/lib/jbossas/server/rhevm-slimmed/deploy/ROOT.war/ to /var/www/html on the -M box

2) copy /usr/share/ipa/html/ca.crt to /var/www/html on the -M box

3) install a fresh copy of rhev-h on the host

3) either disable selinux or fix the missing rules (there are many, many missing rules) on both -H and -M

4) log into the -H box as root and manually start the ovirt service

 

Steps required so that the management platform can add a host directly:

 

Unknown, I couldn't get this to work

And never required for those steps, it always worked out of the box.

Looks like some missconfiguration of the application paths

 

If it's OK by you, I'll ask someone from Red Hat Support to contact you to get the logs and other information that you can provide.

Hi James

 

are you able to do that more than once ?  I didn't work for me.

 

also there are more then one ovirt Service, how did you check that it run right?

 

[root@rhevh3 admin]# chkconfig | grep ovirt
ovirt              0:off    1:off    2:on    3:on    4:on    5:on    6:off
ovirt-awake        0:off    1:off    2:off    3:off    4:off    5:off    6:off
ovirt-early        0:off    1:off    2:on    3:on    4:on    5:on    6:off
ovirt-firstboot    0:off    1:off    2:on    3:on    4:on    5:on    6:off
ovirt-post         0:off    1:off    2:on    3:on    4:on    5:on    6:off
[root@rhevh3 admin]#
 

there is no status command

 

[root@rhevh3 admin]# service ovirt
Usage: ovirt {start}
[root@rhevh3 admin]# service ovirt-awake
Usage: /etc/init.d/ovirt-awake start
[root@rhevh3 admin]# service ovirt-early
Usage: ovirt-early {start}
[root@rhevh3 admin]# service ovirt-firstboot
Usage: ovirt-firstboot {start}
[root@rhevh3 admin]# service ovirt-post     
Usage: ovirt-post {start}
 

thx

Mike

The one I meant as the one that's just named "ovirt".  A reboot of the -H box is also a good idea, and often is enough on its own.

yes I tried it many Times, also disable selinux and start ovirt service and register it.

 

nothing helps.

 

thanks for Help Mike

There's a number of things that could be wrong.

Check forward and reverse dns works for the -M box, and that forward dns works for all -H boxes.  Make sure to change the rhev-m port to 8443 in the config screen of the -H box (assuming you accepted defaults and are using 8443 for your -M box) - it defaults to a different value to the -M box.

 

Redhat: that's a bug that could use fixing actually, both -H and -M sides should default to the same port.

 

Once you've done that, restart the -H box and paste the /var/log/vdsm_reg/vdsm.log (or whatever it's called - going from memory of the logfiles path) if it's still not working.

that could be the case as I don't change the port.

 

I just do a forward installation with Defaults

 

thanks !

I try that out

 

Mike

 

PS: Don't get any Feedback from Red Hat Support yet ;-)

I did follow this thread,

However the last advice you got here was accurate, if you use the defaults there is at the moment discrepancy in the default ports.

One way to check communication between RHEV-Hypervisor and the RHEV Manager is ticking the 'Verify RHEVM certificate' check box. If connection is successful you should get the fingerprint info and be set to go.

Greetings Michael,

 

Are you saying you also filed a support case on this issue, and are still awaiting feedback there? Please let me know...

 

Thanks!

 

Regards,

 

Andrius.

Red Hat, Inc.

Hi Andrius

 

Case Nr is 00526415

 

https://access.redhat.com/support/cases/00526415

 

Michael

Hi Michael, I looked into the case and it shows it has been assigned and is currently being worked. Please be aware that production SLAs do not apply to Beta products. Our goal is a 2-3 day turnaround on Beta issues, but it looks like your assigned TAM is on it already. :-)

 

Hope this helps.

 

Regards,

 

Andrius.

Red Hat, Inc.

Hi Andrius

 

Thx to look into it.

 

I know that the SLA don't apply, neverthenless I like to install it and do some tests.

 

PS: Would be great if the RHEV Product in bugzilla where public visible, then I could follow the Status better.

Thanks for the reply Michael! Yes, we completely hear you - RHEV-M as a product does not have a public Bugzilla product yet, but that is in the works. ;-) Please file support cases for reporting defects in the meantime.

 

Hope this helps!

 

Regards,

 

Andrius.

Red Hat, Inc.

thx

 

Michael

Yay, thanks for posting what you did.  I kept banging my head against the wall until I tried what you posted and was finally able to add a RHEV-H host.

All those steps are not required for registering RHEV-Hypervisor.

So I suspect configuration issues.

Chould you elaborate on your install process?

What I'm specifically suspecting (as the workaround included copy of files from the RHEV Manager specifc folders to the default folder) that you had JBoss already installed or IPA installed manually could you please confirm?

 

Thanks,

Simon.

Hi Simon

 

I have the same Problems.

 

Installation Process:

 

# yum install rhevm

# rhevm-setup

 

thats all

 

Michael

As those steps did not help you, right?

Hi, the install was done onto a fresh machine.  However, I had to re-run rhev-setup (or whatever it's called) a bunch of times due to other bugs, so it's possible that this broke things.  I'll re-run setup on a fresh OS this week and see if it does it automatically when you only run rhevm-setup once.

 

 

Something else that's been troubling me, however, is that if it's correct that RHEV-H boxes aren't intended to be registered with RHN normally, the admin interface should probably be edited to make this more obvious.  Right now when you install a new RHEV-H box, it looks a lot like you're meant to register it with RHN.