rhevm instal problems,

Latest response

Have installed rhevm via yum, and now runnign the install,

 

i get to

 

RHEV Manager will be installed using the following configuration:
=================================================================
http-port:                     8080
https-port:                    8443
host-fqdn:                     RHES6-test
auth-pass:                     ********
db-pass:                       ********
org-name:                      rh
default-dc-type:               NFS
nfs-mp:                        /var/shares
iso-domain-name:               iso
override-iptables:             yes
Proceed with the configuration listed above? (yes|no): yes

Installing:
Creating JBoss Profile...                                [ DONE ]
Creating CA...                                        [ ERROR ]
 

 

 

logs says

 

2011-11-23 14:46:08::DEBUG::common_utils::188::root:: Executing command --> '/etc/pki/rhevm/installCA.sh 1 RHES6-test US rh rhevm ******** 1111221446080000 /etc/pki/rhevm RHES6-t
est.10095'
2011-11-23 14:46:08::DEBUG::common_utils::195::root:: output =  
} Creating CA...

2011-11-23 14:46:08::DEBUG::common_utils::196::root:: stderr = Generating RSA private key, 1024 bit long modulus
..................................++++++
..............................++++++
e is 65537 (0x10001)
Using configuration from openssl.conf
start date is invalid, it should be YYMMDDHHMMSSZ or YYYYMMDDHHMMSSZ
140724253955912:error:02001002:system library:fopen:No such file or directory:bss_file.c:126:fopen('database.txt.attr','rb')
140724253955912:error:2006D080:BIO routines:BIO_new_file:no such file:bss_file.c:129:
140724253955912:error:0E078072:configuration file routines:DEF_LOAD:no such file:conf_def.c:197:
140724253955912:error:0E06D06C:configuration file routines:NCONF_get_string:no value:conf_lib.c:335:group=CA_default name=email_in_dn
file ca.pem does not exist!
2011-11-23 14:46:08::DEBUG::common_utils::197::root:: retcode = 1
2011-11-23 14:46:08::ERROR::rhevm-setup::1006::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-setup", line 970, in _createCA
    out, rc = utils.execCmd(cmd, None, True, output_messages.ERR_RC_CODE, [basedefs.CONST_CA_PASS])
  File "/usr/share/rhevm/scripts/common_utils.py", line 200, in execCmd
    raise Exception(msg)
Exception: Return Code is not zero

2011-11-23 14:46:08::DEBUG::rhevm-setup::1960::root:: *** The following params were used as user input:
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: override-iptables: yes
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: http-port: 8080
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: https-port: 8443
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: mac-range: 00:1A:4A:9C:64:00-00:1A:4A:9C:64:FF
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: host-fqdn: RHES6-test
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: auth-pass: ********
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: db-pass: ********
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: org-name: rh
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: default-dc-type: NFS
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: config-nfs: yes
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: nfs-mp: /var/shares
2011-11-23 14:46:08::DEBUG::rhevm-setup::1964::root:: iso-domain-name: iso
2011-11-23 14:46:08::ERROR::rhevm-setup::2310::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-setup", line 2304, in <module>
    main(confFile)
  File "/usr/bin/rhevm-setup", line 2126, in main
    runMainFunctions(conf)
  File "/usr/bin/rhevm-setup", line 2035, in runMainFunctions
    runFunction(_createCA, output_messages.INFO_CREATE_CA)
  File "/usr/bin/rhevm-setup", line 1397, in runFunction
    raise Exception(instance)
Exception: Failed to create certificate authority

 

Any clues ??

 

 

Responses

Hey Laurence, it looks like this question somehow got posted twice so I deleted the second post.

 

Thanks,

 

Henry

 

Community Manager, Online User Groups

Red Hat Customer Portal

hhutton@redhat.com

start date is invalid, it should be YYMMDDHHMMSSZ or YYYYMMDDHHMMSSZ

 

Laurence, Could you please verify ?

Hey Laurence,

 

It seems that you encountered https://bugzilla.redhat.com/show_bug.cgi?id=755680 (which will be fixed in the GA).

 

Due to this bug, rhevm-setup passes wrong date to the certificate installation script (1111221446080000 instead of 111122144608+0000) in case the GMT offset is zero. The best workaround would be to change the timezone before executing rhevm-setup.

 

Thanks,

Ofer.

Thanks for the feedback, ill adjust and try again,

 

Thanks again

Laurence

hmmm,

 

Changed timezone to UTC and still same issue,

 

 

 

Change the time zone to something that is not UTC or GMT + 0 (Nor GMT + 13)

 

Lets say any GMT + 1 location

 

Reinstall

 

Then you should be able to revert back. The problem is supposed to be just during installation.

 

That worked a treat Simon, Thanks very much , i can move onward now with my trialling

 

All the best

Glad to hear it :)