RHEL (5.7 or 6.1) on an SSD in a laptop will not boot after install

Latest response

I have recently started working with RHEL (in the last 6 months), and decided I should take some preparations, and see about getting my certification.  I bought a book to get started, and went to install RHEL on my laptop.   I also got an SSD (mostly for curiosity), and installed it in the laptop.  The laptop is a Lenovo T60P.  I installed RHEL on the machine while I waited for the SSD to arrive, and everything worked just fine.  The problem is that when the SSD arrived, and I installed it, it will not boot! 

 

When the installer finishes, it has the first reboot, and then finishes the install process.  This works just fine.  The machine is usable, and I can log in, and everything.  When I reboot the machine after that, I get the grub shell, and nothing else.  At that shell, if I do a "root hd0,<tab>", I get the two partitions I created.  One is the boot partition, and the other is the LVM partition.  The boot partition was EXT4, and the LVM had 3 partitions (/, /home, and swap) as EXT4, and swap.  The problem is that they both show up as Filesystem type unknown.  They do have the correct partition types (83, and 8e).  I cannot boot the machine.  Nothing I do seems to help. 

 

I tried to install the /boot partition as EXT3, and that seemed to help, but I still could not boot all the way.  It told me that it could not find the other partitions (even if they were EXT3). 

 

I have tried many combinations of the install, and cannot find a way to get it to work.  I even did the partition on a boundry thing that the RedHat install guide talks about for SSDs. 

 

I have searched for issues with SSDs and lenovo, SSDs and RedHat, and SSDs and EXT4, but I have found no others that have had this issue.  I am sure there are others, and can only imagine that I am not using the correct search terms, or something, but I am getting frustrated.  Has anyone run into this issue?  Does anyone have any ideas on how to fix it? 

 

I have only the free self-supported trial version, so I cannot really rely on support. 

 

Thanks for any help you guys can provide.

 

Jon

Responses

Have you tried switching from IDE to AHCI mode, or vice versa? If you boot off of a rescue ISO or into rescue mode after the install, can you see the VTOC (fdisk -l) and mount any filesystems on the SSD?

"grub-install" should let you reapply the boot loader from a rescue mode boot, and you can use fdisk to mark the appropriate partition as bootable/active if necessary.

Additional info... take a look at this SATA/Linux page for information on Thinkpads, including known issues with the T60 series with Linux.
http://www.thinkwiki.org/wiki/Problems_with_SATA_and_Linux

A "normal" VTOC with bootable partition and LVM looks something like this:
[root@inception ~]# fdisk -l

Disk /dev/sda: 53.7 GB, 53687091200 bytes
64 heads, 32 sectors/track, 51200 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0007bac5

Device Boot Start End Blocks Id System
/dev/sda1 * 2 501 512000 83 Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2 502 51200 51915776 8e Linux LVM
Partition 2 does not end on cylinder boundary.

Dear Phil,

 

I have question about SSD. I hope you will give me the solution. Can I install RHEL5.x on SSD? Which version of Red Hat is support SSD? Or which filesystem (ext3/ext4) supports SSD?

 

 

 

/shyfur

Yes, Most of these things I have tried.  The IDE (compatability) vs AHCI was one of the first things I tried.  The bootloader does not seem to be able to access any information from the disk at all other than that is is there, and has two partitions.  When I boot in rescue mode, it tells me that I don't have any Linux partitions. 

 

fdisk -l shows the two partitions, the blocks and ID/system.  They appear to be correct.  Everything ends on a boundry, so I don't get the errors for that.  It is using 32 heads and 32 cylinders as suggested by a redhat article on SSD.

 

The site you list is one that I looked at, but none of the issue looked like what I am experiencing.  I looked again, and see this at the bottom:

 

RHEL3.0 Update 7 will install on a T60p, but you need to make an adjustment. Both uni-processor and SMP kernels get installed, with the SMP kerrnel the default. However, the SMP kernel can't seem to find the disk drive. You can work around this by use "e" at the GRUB kernel prompt, then on the "kernel" line appending " noapic". After the system boots, you'll want to edit /boot/grub/grub.conf to add the " noapic" option to the kernel line as well.

 

I am afraid I am familiar with lilo, and not at all with grub.  What is the 'e' at the GRUB kernel prompt?  It tells me it is an unrecognisezed command when I type it and hit enter. 

 

Thanks for the help.

Jon

So, I reloaded the machine again so that I could get a look at things from the running system (before the first reboot).  Several things are very bad.

 

First, there is nothing at all in /boot! 

Second, When doing an fdisk -l, I get the same error over and over, Disk /dev/mapper/vg_rhel-<lv_whatever> doesn't contain a valid partition table.

Last, when I try to fsck to check for problems, it tells me that the superblock has an invalid journal, and when it corrects that, it says the ext3 journal is gone making it ext2.  It should be ext4!

 

So, I think that it may be that RedHat is just not compatable with the machine, and I may have to run KVM on a different platform (I know Slackware works, as I have used it before wih the SSD, just to test), unless someone has a better idea.

 

Jon

 

*Edit*

After closer inspection, it appears that the entire file table is hosed.  Most of the files show up with no file name, or uninteligable ones.  It get's worse the longer it runs.  I now have nothing at all in /!  No files, no folders, but the machine is running...   I can cd into the directories that it does not show, but everything is wrong.

Just to confirm, are you mounting and checking the filesystems with fsck.ext4 and mount -t ext4? Its okay that the LVM volumes do not have partition tables on them.