RHEV 3.0 beta bugs

Latest response

[EDIT: This discussion is becoming difficult to follow due to numerous separate issues. If you have a bug or issue relating to RHEV or the RHEV 3.0 beta, please create a new discussion for it. Thanks! -Admin]

 

There are many bugs with the 3.0 beta.  This is expected, even if some of them are a bit embarrassing (e.g. that you can't register a RHEV-H box to RHN if your RHN password has spaces or special characters - there's zero attempt at escaping or quoting params passed to the shell in basically all of RHEV, which often causes large amounts of brokenness).

 

However, there's nowhere in bugzilla that I can find to file bugs for any part of RHEV.

 

I'll put a few examples in this post, some of which are very serious:

  • No escaping or quoting of shell commands, anywhere
  • RHEV-H install interface often fails to work entirely if the primary hard disk is not empty
  • RHEV-M setup script assumes that a remote auth domain will use a FDQN (not always the case with AD domains)
  • RHEV-M setup script when re-run due to an error the first time around, adds clone entries to the postgres DB, which breaks login entirely.  Easiest fix seems to be dropping the database, running ipa-server-setup --uninstall and starting again, but this is not documented.
  • RHEV-M setup often thinks IPA setup worked when it hasn't
  • RHEV-M won't add RHEV-H 6.2b hosts out of the box.  The RHEV-M message is "install failed.  Consult logs for details" -- although it doesn't specify which logs, and I've been unable to find anything useful on the RHEV-M box.
  • RHEV-H 6.2b won't register with RHEV-M 3.0b out of the box.  It tries to get a bunch of things from /var/www/html on the -M box, which fails, as that dir is empty.  Copying the files from /var/lib/jbossas/server/rhevm-slimmed/deploy/ROOT.war/ helps, but the SSL negotion still fails.
  • Even when the above SSL error is fixed, it's still impossible to register the host to RHEV-M as it tries to call /RHEVManagerWeb/VdsAutoRegistration.aspx, which does not exist.
  • RHEV-H 6.2b doesn't appear to register properly to RHN - it seems to want a full RHEL entitlement, and fails if there are only RHEV entitlements available.

 

There are many, many more bugs, but this is a start.  It'd be nice to have some way of submitting them so they can be fixed

Responses

I hope you don't mind, it's just easier for me this way.

The other topics not addressed in the following comments will be reported Bugzilla entry doesn't exist already.

 

Thank you very much for this detailed feedback

RHEV Hypervisor does not need to be registered to RHN in order to serve as an hypervisor.

However if you intend to use RHEL based guests then you have the option to register it to RHN in order to use existing RHEL entitlements for virtual guests.
 

Right, but unless it is, it won't get updates (and means that I'm stuck with the bizarre package selection, where there are various man pages installed, but no man command, for example)

use of RHEL Virtualization entitlements for RHEL guests running on it. Not for updates in any case, please look at RHEV Hypervisor as monolithic entity for now.

RHEV Hypervisor updates is done differently, either by yum update/install the rpm containing the ISO image in the RHEV-Manager, and then use RHEV Manager to update the node, or by direct update using CD/PXE.

 

There is a section in the documentation that elaborates the available procedures.

 

Discussion moved to https://access.redhat.com/discussion/rhev-hypervisor-registration-rhev-manager

Thanks for reporting. I'll follow that with engineering, chould not find open BZ on this one.

 

In the meanwhile the solution should be uninstall and install in case of initial installation failure

 

If however what you want to do is to change installation parameters - you should use the rhevm-config utility

You are correct, this was a debated issue hence did not make it into beta, the are just to may corner cases to recover from in case the installer has failed, hence the decision is to have rhevm-setup for clean install. So what will be added is a check for existing installation, If one exists, the script will allow to purge everything and reinstall or quit.

For upgrade/fix installation based on current configuration and data base please use the rhevm-upgrade

To modify exiting configuration you have the rhevm-config

 

This discussion has been moved to the Users & Directory Services subgroup: https://access.redhat.com/discussion/rhev-m-setup-often-thinks-ipa-setup-worked-when-it-hasnt

Not sure if anybody else ran into this, but when I got to the part in the instructions where I ran rhevm-reports-installer, I got a lot of FATAL where it was failing to access postgres. I found that /var/lib/pgsql/data/pg_hba.conf was overwrote and the old one moved to pg_hba.conf.orig. The changes were the auth method from trust to md5, which caused the fail. After fixing that mess, I had to restart jbossas and tomcat6 to get the page to pull up.

I believe the documentation is confirmed as incorrect and is slated to be updated - the preferred method is to issue a 'rhevm-reports-setup' instead of 'rhevm-reports-installer'

 

Andrius

Red Hat, Inc.

Is ther way to log on to IPA ...Can anyone provide more details..

If so then the simplest way would be in the RHEV Maneger server shell run: kinit admin
After typing the password you've used during setup you can run any IPA command line. To see the available commands just type ipa and the tab key for auto completion.

In the quick start guid you'll find an example of adding users and setting passwords.

I am currently working on a POC between RHEV and Xenserver, and so far i have gotten verfy far with RHEV-m 3 beta.  I am still unable to add a host to the manager.

 

I have an open ticket right now: https://access.redhat.com/support/cases/00532633

 

here are the logs from one of the hosts -

MainThread::DEBUG::2011-09-21 19:19:14,912::vdsm-reg-setup::205::root::execute: after getAuthKeysFile: True
MainThread::DEBUG::2011-09-21 19:19:14,913::vdsm-reg-setup::119::root::registerVDS begin.
MainThread::DEBUG::2011-09-21 19:19:14,913::vdsm-reg-setup::128::root::registerVDS URI= /RHEVManagerWeb/VdsAutoRegistration.aspx?vds_ip=10.1.224.46&vds_name=virt03.atlc1&vds_unique_id=%23%20SMBIOS%20implementations%20newer%20than%20version%202.6%20are%20not%23%20fully%20supported%20by%20this%20version%20of%20dmidecode.32393735-3134-5533-5631-313133314842_3c%3A4a%3A92%3Aeb%3A94%3A94&port=54321&__VIEWSTATE=

MainThread::DEBUG::2011-09-21 19:19:15,031::vdsm-reg-setup::160::root::registerVDS status: 500 reason: Internal Server Error
MainThread::DEBUG::2011-09-21 19:19:15,032::vdsm-reg-setup::179::root::registerVDS end.
MainThread::DEBUG::2011-09-21 19:19:15,032::vdsm-reg-setup::210::root::execute: after registerVDS: False
MainThread::DEBUG::2011-09-21 19:19:15,032::vdsm-reg-setup::216::root::Registration status:False
MainThread::DEBUG::2011-09-21 19:19:25,043::vdsm-reg-setup::270::vdsRegistrator::Total retry count: 5, waited: 10 seconds.
 

in beta1, you need to fix the rhev-m url to have port 8080 or 8443 on the rhev-h side.

does this help?

after adding a host in the RHEL Admin portal, the host loads all the software, reboots, then reports as "Non Responsive".   Going from Maintenance mode and back to Activate, does not change the Status from Non Responsive.

 

Is there some debugging path I should be following to resolve this?

 

My channel subscriptions:

rhel-x86_64-rhev-mgmt-agent-6-beta
rhel-x86_64-server-6
 

Should I also use "rhel-x86_64-server-6-beta" when working with RHEV v3 beta?

 

Thanks!

Open the firewall ports as per instructions here :

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.0/html/Installation_Guide/sect-Installation_Guide-Using_Red_Hat_Enterprise_Linux_Hosts.html#Preparing-RHEL-Hosts

 

This should get your host up.

thanks for the response.   The firewall looks okay, see the bottom.

 

I get one message about "conflicting packages cman not installed" at the beginning.

 

But later, after the reboot, rhev-m renames the server from decatur to decatur.ctgcentral.com, resulting in 2 host entries.   The first entry is non-responsive.   The second entry needs approval.   After approval, rhev-m tries some installing and fails quickly.

 

It may be a DNS issue.   I am not using DNS for this host, just /etc/hosts on the rhev-m and rhev-h host.   Maybe the Win Desktop needs /etc/hosts changed as well??

 

 

# iptables -L -n
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED
ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:22
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:16514
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:54321
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           multiport dports 5634:6166
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           multiport dports 49152:49216
REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         
REJECT     all  --  0.0.0.0/0            0.0.0.0/0           PHYSDEV match ! --physdev-is-bridged reject-with icmp-host-prohibited


Paul,

 

Would be helpful to know the errors you see in the 'events' section of the admin console.

 

In any case, I would recommend you to the following post for setting up the environment:

https://access.redhat.com/discussion/setting-dns-prior-installing-rhev-m-30-beta

 

Also, the installation guide has details on the channels that need to be subscribed and takes you through the install process with screen shots on what to expect at each step :

 

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.0/html/Installation_Guide/index.html

 

If you still experience errors, please log a support call as it will enable us to gain access to the logs and determine the cause.

 

Hope this helps.

Thanks.  

 

I have reloaded the RHEL host using PXE to start again.  

 

The Install Guide doc you pointed to in newer than what I was following.   I already see in Chapter 8 some important points that should make a difference.   I will update this post later with my results.

 

Here is an update:

I reinstalled with the RHEL v6 beta channels, but first I added the hosts (rhev-m and rhev-h) to DNS forward lookups.   I couldn't easily get reverse lookup, so I did not do it.

 

I added these channels:

RHEV-H

rhel-x86_64-rhev-mgmt-agent-6-beta
rhel-x86_64-server-6
rhel-x86_64-server-6-beta

RHEV-M

rhel-x86_64-server-6
rhel-x86_64-server-6-beta
rhel-x86_64-server-6-rhevm-3-beta
rhel-x86_64-server-6-rhevm-3-jboss-5-beta
rhel-x86_64-server-supplementary-6-beta

 

The first "Add Host" attempt failed with "No package fence-agents available".   This rpm is in the rhel-x86_64-rhev-mgmt-agent-6-beta channel.  So, I did "yum clean all" and "yum info fence-agents" to check the channel access.   That worked, so my re-install of the host from the rhev-m console worked as well.

 

Paul

 

If RHN happens to be slow at the time, or your servers are in IP space for which GeoIP lookups tend to fail (e.g. you have PI addresses not the usual PA) the installation of a RHEL host will tend to fail multiple times due to timeouts downloading and installing the vdsm and related packages.

 

It would be nice if there was a more intelligent "is this still doing stuff" check rather than a "has it taken more than X seconds"

It will be changed in future releases.

 

Thank for the feedback.

 

 

If a username has hyphens in it a row change comes after each hyphen when the username is printed on the user portal web page. Now the Sign out, Guide and About links are "hidden". See pictures:

 

http://img194.imageshack.us/img194/3351/kuva.png

http://img269.imageshack.us/img269/7145/kuva2h.png

Having more than one data domain attached to a single datacenter causes problems.  Putting the non-master domain into maintenance mode can cause the master domain to fail, bringing down the DC entirely.

 

It's also not possible to have disks from more than one storage domain attached to a VM, nor is it possible to specify which storage domain a disk should come from when attaching a disk -- this is possibly a RFE, although as it makes RHEV close to useless for disk management beyond basic OS disks, it's a pretty important one.

 

 

This should actually work and I've done so multiple times.
Could you please contact support and provide them with the full description and the logs?

If you'll return to me with the case number I can expedite the investigation into that

In regards to your comment at https://access.redhat.com/discussion/rhev-30-beta-bugs#comment-19525, you are correct and this already has a RFE with high priority.

In regards to your comment at https://access.redhat.com/discussion/rhev-30-beta-bugs#comment-19525.

 

If you'll look at the new disk dialog you'll see that you have a drop down list allowing you to select the storage domain. The only limitation is that this storage domain isattached and activated on the data center you've placed your virtualmachine

 

Screenshot-rdesktop - 23.2.2.11.png

After RHEV-M installation. RHEV-M installer should change content for iptables config file.

 

 

[root@rhevm sysconfig]# /etc/init.d/iptables restart
iptables: Flushing firewall rules:                         [  OK  ]
iptables: Setting chains to policy ACCEPT: nat filter      [  OK  ]
iptables: Unloading modules:                               [  OK  ]
iptables: Applying firewall rules:                         [  OK  ]
[root@rhevm sysconfig]# /etc/init.d/iptables save
iptables: Saving firewall rules to /etc/sysconfig/iptables:[FAILED]
[root@rhevm sysconfig]# ls -lZ /etc/sysconfig/iptables
-rw-------. root root unconfined_u:object_r:system_conf_t:s0 /etc/sysconfig/iptables
[root@rhevm sysconfig]# ls -lZ /etc/sysconfig/iptables.
iptables.old   iptables.save 
[root@rhevm sysconfig]# ls -lZ /etc/sysconfig/iptables.old
-rw-------. root root system_u:object_r:system_conf_t:s0 /etc/sysconfig/iptables.old
[root@rhevm sysconfig]# tail -n2 /var/log/audit/audit.log
type=NETFILTER_CFG msg=audit(1320337647.203:1578): table=filter family=2 entries=4
type=SYSCALL msg=audit(1320337647.203:1578): arch=c000003e syscall=54 success=yes exit=0 a0=4 a1=0 a2=40 a3=964340 items=0 ppid=4789 pid=4865 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=205 comm="iptables-restor" exe="/sbin/iptables-multi" subj=unconfined_u:system_r:iptables_t:s0 key=(null)

After running rhevm-setup and allowing it to create iptables for me

 

-rw-------. root root system_u:object_r:system_conf_t:s0 /etc/sysconfig/iptables
-rw-------. root root system_u:object_r:system_conf_t:s0 /etc/sysconfig/iptables-config
-rw-------. root root system_u:object_r:system_conf_t:s0 /etc/sysconfig/iptables.old
 

These are the expected values.

 

I did start with a fresh installation of RHEL6.2-beta, could it be that you have modified the rules manually?

No. I didn't modificate content. Besides I change content to system_u:object_r:system_conf_t:s0 but It was rewretten after restarting iptables. I think this is not RHEV related issue

Discussion moved to RHEV-M subgroup:  https://access.redhat.com/discussion/status-vm-becomes-not-responding-vm-works

This comment and related replies have been moved to its own discussion at https://access.redhat.com/discussion/having-trouble-seeing-uploaded-iso-files

 

 

 

 File "/usr/bin/rhevm-setup", line 2304, in <module>
    main(confFile)
  File "/usr/bin/rhevm-setup", line 2126, in main
    runMainFunctions(conf)
  File "/usr/bin/rhevm-setup", line 2035, in runMainFunctions
    runFunction(_createCA, output_messages.INFO_CREATE_CA)
  File "/usr/bin/rhevm-setup", line 1397, in runFunction
    raise Exception(instance)
Exception: Failed to create certificate authority

 

I have installed RHEV-H on IBM x3650M2 server.

 

1) UEFI boot doesn't work. As I discussed in IRC It's known bug.

 

2) I cannot start network on RHEV-H fresh installation (there is empty mask error in ovirt.log, but correct mask is in ifcfg-breth1 file. For information ip/mask 172.17.192.140/255.255.255.192). I haven't reproduced this bug on another installation yet. 

 

 

unable to determine ip/netmask from:
lo
breth0: static 172.17.192.140
breth1: static 172.17.192.140

{'breth1': ('172.17.192.140', ''), 'breth0': ('172.17.192.140', '')}Hardware virtualization detected
checking for lockfile
current page: 1
eth0
unable to determine ip/netmask from:
eth1
unable to determine ip/netmask from:
usb0
unable to determine ip/netmask from:
bond0
unable to determine ip/netmask from:
bond1
unable to determine ip/netmask from:
bond2
unable to determine ip/netmask from:
bond3
unable to determine ip/netmask from:
bond4
unable to determine ip/netmask from:
breth0
unable to determine ip/netmask from:
breth1
unable to determine ip/netmask from:
eth0.516
unable to determine ip/netmask from:
eth1.516
unable to determine ip/netmask from:
lo
breth0: static 172.17.192.140
breth1: static 172.17.192.140

{'breth1': ('172.17.192.140', ''), 'breth0': ('172.17.192.140', '')}Hardware virtualization detected
current page: 1

I'd like get online debuging network issues (not only livecd)

So I've found root console :)

 

1'm sorry. I think that this's network related issue (not a bug). I'll start new topic or ask in IRC.

I've been doing a bit of tidying up in this thread, moving discussions for separate issues into separate threads. Rather than add unrelated issues to this thread, please create new threads for your RHEV bugs and issues.

Thanks!

David Powles
Community Administrator
Red Hat Customer Portal User Groups

I have installed RHEV (with FreeIPA).

 

There are two networks in RHEVM. Display network 172.17.205.200/29 and rhevm network 172.17.192.128/26. Display and rhevm networks are in different VLANs. Both RHEVM and RHEVH hosts has display and rhevm IPs.

 

There are two desktops which connect to network via Cisco VPN. First (adminitrator) desktop has access to rhevm and display network. RHEVM and spice work fine. Second desktop has not access to rhevm network (Cisco admin prohibits this access). User can access UserPortal but spice doesn't work because spice client tries to connect to rhevm IP.  So all spice traffic goes throught rhevm network. Why?

 

Sorry. I didn't see admin message.

 

I've created new discussion in Networking section.

 

https://access.redhat.com/discussion/display-network-doent-work-me